WordPress.org

Support

Support » Plugins and Hacks » Multiple content blocks » [Resolved] HTTP Request Error in 3.1

[Resolved] HTTP Request Error in 3.1

  • I’m getting the HTTP Request Error in the latest 3.1 version of the plugin when I have any other plugins active. Even Hello Dolly seems to mess with it. With everything disabled there is no error and the content is ok. But any other plugin causes the all of the post URLs to return 404s. With everything deactivated except for MCB it’s ok but as soon as any plugin is added all of the posts fail to load and I see the HTTP Request Error on the backend.

    Any suggestions on lines that I can try removing to see if it helps in the new version? Line 69 seems to be a blank line in version 3.1

    http://wordpress.org/plugins/multiple-content-blocks/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Trendwerk

    @trendwerk

    Wow, that sounds really strange. No other plugin should have any effect on MCB like that. Is it possible your website loads quite slow and the HTTP request times out? Maybe when activating another plugin it just gets that little bit of extra slow. I can’t think of anything else.

    You can try going to Settings -> Multiple content blocks and disable “HTTP Requests”. You will have to initialize the blocks manually by visiting the page in the front-end.

    Hope that helps.

    It turns out this was a really odd problem with the theme. There were some errors with how it created the custom post types and that caused problems when MCB tried to update fields. Fixing the ‚Äéregister_post_type function fixed it.

    Plugin Author Trendwerk

    @trendwerk

    Ok, I’m glad it worked out.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] HTTP Request Error in 3.1’ is closed to new replies.
Skip to toolbar