• Resolved relish1227

    (@relish1227)


    As requested (https://wordpress.org/support/topic/sudden-problems/#post-13163664) starting a new thread for this issue:

    My client alerted me to a Google search Console “coverage issue” related to a “server error (5xx). Here’s a screenshot to what I see: https://snipboard.io/whQekL.jpg

    The URL itself is not tied to an existing page but should be redirecting to the new version of the URL.

    What I discovered in looking into this again is that I had this sort of redirect setup:

    FROM /community/karsten-cove
    TO /community/albertville-karston-cove/

    This actually works. But, the error is happening on “/community/karsten-cove/” — with a trailing slash. So I added a second redirection rule:

    FROM /community/karsten-cove/
    TO /community/albertville-karston-cove/

    This does not work. When I choose “Check Redirect” within WP for that rule, I get a 500 error. It says in the popup:

    Expected: 301 to /community/albertville-karston-cove/
    Found: 500
    Agent: Not using Redirection

    As mentioned in the previous thread, I had previously copied my site to staging, deactivated all plugins except Redirection, and switched theme to Twenty Twenty. Still seeing it, whether logged in or not.

    I went back to the staging site and added the second redirect rule, with the ending-slash. But, now, both redirects are sending me to the home page?

    Any help you can provide would be appreciated. Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author John Godley

    (@johnny5)

    Can you provide full URLs for this?

    Thread Starter relish1227

    (@relish1227)

    Plugin Author John Godley

    (@johnny5)

    Ok, I can see the results of those two URLs. I do not know why you get the 500 error, and I don’t think it is caused by Redirection.

    If you disable Redirection it is possible the error will continue.

    Note you don’t need two redirects – one redirect with ‘ignore trailing slash’ should suffice.

    Thread Starter relish1227

    (@relish1227)

    Thanks for confirming re: not needing two redirects.

    I just took a fresh copy from production and placed on a staging location. When I deactivate Redirection, this URL (which triggers the 500 when Redirection is active) goes instead to a 404 page:

    https://centrahomes.staging.wpengine.com/community/karsten-cove/

    Plugin Author John Godley

    (@johnny5)

    I don’t know why this would happen, and I don’t know how to recreate the problem. I suspect it is something specific to your set up. Redirection is sending a correct status code, and something else must be changing it in some way.

    Ran into this exact error today. It appeared that WordPress was automatically redirecting the post in question, (info on automatic redirection via the below link) causing problems with an identical redirect manually setup in Redirection. Perhaps @relish1227 was seeing a similar problem.

    https://wordpress.stackexchange.com/questions/183598/removing-the-redirect-after-changing-a-pages-slug

    Every WordPress post has its own slug, which is automatically generated by your post’s title. If you decide to change the post slug later, WordPress will remember the old one and redirect it to the new one. It’s possible to prevent old post slug redirection in WordPress by adding removing a couple of actions from your WordPress core with a small snippet.

    Thread Starter relish1227

    (@relish1227)

    I returned here today because my client notified me of a Google Search Console 5xx error. It turned out to be a redirect created by WordPress (as @mrbum21 is also seeing). When I clicked “Check Redirect” the popup said the following:

    
    Check redirect for: https://www.centrahomes/community/riverwoods-national/
    Expected 0 to /community/riverwood-national/
    Found: 500
    Agent: Not using Redirection
    Cannot connect to the server to determine the redirect status
    

    I then went in to edit the Redirect and changed the “Group” from “Modified Posts” to “Redirections.” After that, the “Check Status” message is good, I get a 301 and the Agent is “Using Redirection.”

    If WordPress already does its own redirection, perhaps it’s best to just not use Redirection for this purpose — does that seems correct? I could uncheck the various boxes I’ve had set in the Redirection settings in the “URL Monitor.” It’s monitoring changes to posts and custom post types.

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“HTTP redirect status code must be a redirection code, 3xx.”’ is closed to new replies.