http mistake (6 posts)

  1. sfvisie
    Posted 4 years ago #

    After moving my WordPress Multisite installation to a new domain name I have problems with reaching the network admin. The admins of seperate sites are working fine, but the network admin doesn't work. It points to http://http//domainname.com/wp-admin/network/.
    I searched the database, wp-config and htaccess file for "http//" so I could correct it, but I can't find it anywhere :( In which file I can correct an error like this?

    Thank you in advance,

  2. In wp-config, what is 'DOMAIN_CURRENT_SITE' set to?

    And in your DB, check that wp_site has just domain.com (not http://domain.com)

  3. adrixe
    Posted 4 years ago #

    I have this problem as well. cant access the network admin.

  4. sfvisie
    Posted 4 years ago #

    Thank you Ipstenu.

    Domain_current_site wp-config was:
    define( 'DOMAIN_CURRENT_SITE', 'http://domain.com' );
    I deleted the http:// part, and the the login screen was available again, but I wasn't able to login
    I checked wp_options siteurl and saw it was written as http://www.domain.com/. I deleted "www." and now it works again :)

  5. sfvisie
    Posted 4 years ago #

    But new problems appeared :(

    1) I can only login in the admin of any site using Internet Explorer. Firefox or Opera keep returning to the login page.
    2) All link structures are OK (for example site.com/page), but if I click on it or load that link directly, I'm redirected to the frontpage. Before the new URL it worked fine. Non-existing links are just showing the Error 404 page. In admin panel the "Settings > Permalinks" is messed up.

  6. Can you get into http://domain.com/wp-admin/network/sites.php ? If so, go in to EDIT the site #1 and make sure the domain is in there WITHOUT the www part.

    Check the box for 'change both home and site URLs' and hit save.

    (This is why I tell y'all NOT to use www in the domain for Multisite. :/ )

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.