Support » Plugin: SSL Insecure Content Fixer » http:// & https:// URL settings

  • Resolved Group Of Oceninfo

    (@princebhalani143)


    Hello,

    I am getting Mixed Content error and looking for some solution then I have came across your plugin but before installing this plugin on my live website I want to ask one question as below.

    I want to run http:// & https:// both together without forcing https:// to the full website. Is it possible to supply // in all URL instead of http:// or https:// so it’ll take automatically http:// by default and when user land using https:// it’ll automatically take https:// and it’ll also resolve issue as well.

    Is it possible to do with this plugin? without forcing https:// to complete website run as flexible as we want.

    Waiting for your favorable reply.

    Thanks,
    Group of oceninfo

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author webaware

    (@webaware)

    G’day Group of oceninfo,

    This plugin will on-the-fly change some links to assets like images, stylesheets, scripts. It does not change any other links, so it can be safely used on a site that switches back and forth between http and https.

    Because it changes things on-the-fly, you can activate the plugin to get some fixes, and deactivate the plugin to go back to the old state. This allows you to make permanent fixes at your leisure, or not at all.

    For the assets it fixes, it replaces http with https. This is best, because // (protocol-free URIs) are not always valid — think about emails, for example, where an html email loaded in an email app won’t have a protocol. // has even been called an anti-pattern.

    cheers,
    Ross

    Hi Ross,

    Thanks for your reply.

    Yup your reply make more sense change URL and fix and disable plugin but Website is too big and I don’t want to take any risk so I have done some more google and came across that issue was because of W3 Total cache plugin. It’s fixed under W3 Total Cache as below.

    I have to mark Cache SSL (https) requests, Cache SSL request ticked and resolve my http & https caching issue that’s why it was giving me an error of mixed content

    Thanks again for your response.

    Regards,
    Group Of Oceninfo

    Hello WebAware, I too just installed your plug-in on my site and the mixed content error is still there. I noticed that when I perform a page refresh the lock turns green for a second and then goes back to gray. This happens each and every time using Firefox. Also I am not seeing any errors in Firefox Web Tools.

    My entire site is supposed to force SSL so not http is involved.

    https://theballisticscenter.com

    Thanks,
    Jim Lucore

    Hi,

    I have tried this plugin and it fixed mixed content error on home page but for other page like about, service, portfolio it’s still serving http:// image file.

    All Cache are cleared and tested but still no pad lock on some of the page.

    I have select option as Widgets so it’ll cover Everything that content & simple covered.

    Waiting for your favorable reply.

    Thanks,
    Group Of Oceninfo

    Have you made the change in WordPress to tell it your site is now HTTPS and not HTTP? YOu have to force your site from http to https and then activate the plug-in. There are a couple of ways to force https on your site, google “WordPress Force HTTPS” and see what to do.

    Yup I am forcing every URL as https but only that image is not picking as https

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘http:// & https:// URL settings’ is closed to new replies.