Support » Fixing WordPress » HTTP errors on media uploads after 4.5 update

  • Hello,

    I’m getting HTTP errors on media uploads after 4.5 update.

    Please fix that!!!!1

    Thank you

Viewing 15 replies - 46 through 60 (of 66 total)
  • Thank you, NealGhoshal

    SetEnv MAGICK_THREAD_LIMIT 1

    Worked for me. We just migrated to a different host and this issue popped up. Sticking it in the first line of .htaccess did the trick.

    i add the artdesigner code, the image uploaded but doesn’t create thumbs (wordpress 4.6.1)

    any help?

    I was having the same problem. I tried multiple different things with no success, including contacting my hosting company. I always use webresizer to resize my photos and had no problems. I decreased the photo slowly and was able to upload files as large as 54kb. Semi-success. Any larger than that and I received the HTTP error. This began happening after I switched to the Optimizer theme. I tried switching to Twentysixteen and was able to upload photos without a problem. Definitely somewhat of a bummer as I really like the Optimizer theme. I hope this helps someone else figure out this crazy problem! Additionally, if you want to try to get around this when uploading post photos, try uploading your photo to Photobucket, right click on the image and copy image address. Then paste the image address into the code below.

    <img src="PASTE IMAGE ADDRESS HERE" alt="" height="500" />

    Next, copy the entire line of code and paste it into your post draft. Make sure the text option is selected rather than the visual tab. You should now be able to adjust the size of the image by playing with the height and adding width if need be.

    Good luck!

    • This reply was modified 3 years, 3 months ago by strivehere.
    • This reply was modified 3 years, 3 months ago by strivehere.

    Here is the solution to your sound/media files failing to upload into your Media Library.

    I have now uploaded 8 x 20 minute MP3 audio files to my website: ifpainpersists.com without any hiccups!

    Firstly go to – http://www.nch.com.au/software/macaudio.html?gclid=CM20qpWHk88CFYWYvAodMrcKgA

    Top left hand corner, click on Download Mac for WavePad Audio Editor, save zip file.

    Open your sound file and “save as” (remembering to rename it as WavePad to distinguish it from your original sound file)

    Save into WordPress media library (add new) as you would do normally, be patient and wait until you see the the word “crunching” before you touch ANYTHING! Your file should then appear in your Media Library.

    Don’t ask me why this works – perhaps I am an accidental genius!!!!

    John Blackman
    Melbourne Australia

    where do you find .htaccess? Any help will help. If I can get a step by step that would be better. New to this coding thing and just trying to add images but I also get HTTP error

    I contacted my web host and asked them to increase my memory. They walked me through it and I no longer receive the HTTP error when uploading photos. During that time, I discovered that I was using a very old version of PHP, I updated to the newest version. I was then able to lower my memory limit and upload photos without a problem.

    Hello.
    I’m having a similar problem…
    Upload ímages painfuly slow… but this probelm occurs only with images I already tried to upload other files (pdf, docs) and the upload is fast…

    I already to talked to my host provider and they cannot resolve this problem.

    It´s possible to be an error from the WORDPRESS.. I updated the sites to latest version, and i think it was a that time that this problem of slowness upload of images happened..

    Do you resolved this problem? I you did please could you explain how?

    Thanks

    @cloudsidea Where you able to increase your memory? That is what worked for me. I asked my host how to do so and they walked me through it. I hope you get the issue figured out soon, I know it is quite frustrating!

    We were facing same issue on client’s website.
    STEPs to resolve the issue are:
    1. Make sure that your host fulfills https://wordpress.org/about/requirements/
    2. SetEnv MAGICK_THREAD_LIMIT 1
    3. Increase memory & execution time

    If you are still facing the issue, share the credentials of server we are more then happy to help on resolving the same.

    Gracias DoctorMicro, su línea de código me ha funcionado. El conflicto lo creaba Wordfence, si lo desactivaba todo funcionaba normalmente.
    Desconozco como es todo el problema, pero lo cierto es que funciona…!!! Muchas Gracias.
    Saludos desde Argentina.

    Tried everything listed here and no luck.
    I get HTTP error on all images upload to Media Library.
    Please fix this in wp 4.6.2

    For some reasons, we’ve had the HTTP errors issue happening too, for all users, but Admins – starting with WP 4.6.1. For whatever reason, granting the “delete_users”-permission to a users role, fixed the problem for users with that role. I doubt this is desired functionality, but it might be worth a try for those still looking for a solution.

    • This reply was modified 3 years, 1 month ago by Mario Rader.

    This is NOT a wordpress problem for my case anyway.

    I have 10 websites on my VPS server and the main domain/site have WordFence enabled so the other sites where influenced by the root .htaccess with the WordFence codes. The developpement website with which I had this HTTP error issue WAS NOT WORDFENCE enabled but was still “seeing” the root’s .htaccess

    So, I know now that I have to enable WordFence on ALL my websites on the same server.

    There you go!
    Mario Bruneau

    g05k3539

    (@g05k3539)

    Hey,
    I had an issue too and found out that my share host was running php version 5.5.36. I had to add ”AddHandler application/x-httpd-php56 .php” to the .htaccess file to get the server to run php 5.6

    I hope this helps

    This error appear after add the code in the function.php

    Fatal error: Cannot redeclare change_graphic_lib() (previously declared in /home/cryo64c/public_html/blog/wp-includes/functions.php:4) in /home/cryo64c/public_html/blog/wp-content/themes/betheme/functions.php on line 182

    My WP is installed on a subdirectory “/blog”

    http://cryo64.com/blog/
    Please help!

Viewing 15 replies - 46 through 60 (of 66 total)
  • The topic ‘HTTP errors on media uploads after 4.5 update’ is closed to new replies.