Support » Fixing WordPress » HTTP errors, IO errors, and Operation time-outs when uploading images

  • Hello,

    I have read a lot of posts about this issue on here, but most seem to be form 1 year+ ago – so wondering if anyone is having these issues with WordPress 3.3.1 / 3.3.2?
    I was having the issues yesterday so updates my site to 3.3.2 thinking this may solve it but still having issues.
    Most of the time i get the ‘HTTP error’ message, but then sometime’ ‘Operation timed out’, then sometimes ‘IO error’ – it’s driving me crazy – especially trying to explain to my client what the heck is going one, as intermittently we are able to upload an image, then it goes back to not working again!

    Anyone have a solid answer yo how to fix this, but get onto it WordPress guys it is a big issue!!! 🙂

    Thanks in advance

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi

    (@esmi)

    Forum Moderator

    That sounds like a server issue to me. Have you spoken to the hosts about it?

    No but i will now and see what they say, thanks!

    I am still waiting to hear back form my hosting company on the issues i had on the first website yesterday, but now I am having the same issues with ANOTHER website which is hosted with a DIFFERENT company – trying to upload images and getting ‘Operation timeout’ or ‘HTTP error’ messages – seems a coincidence that both hosting companies are having server issues….?

    I have tried this on both PC and Mac in different browsers, and both time have had strong internet connection, at Home 30GB Virgin media broadband and secondly at work in a shared office with high bandwidth connection….

    I’m a bit scared of playing with the .htaccess file as know nothing about these but can see suggestions for adding bits of code to this on other forums.. sit this the next route to go down…?

    Many thanks!

    esmi

    (@esmi)

    Forum Moderator

    See http://wordpress.org/support/topic/164999
    Also ask your hosts if your domain is set to use PHP as FastCGI or an Apache Module. FastCGI will cause upload errors.

    Great thanks i’ve never heard of these – so I ask them to make sure PHP is in Apache mode? – I presume they should be as I use Bluehost and another which were recommended by WordPress.
    Thanks
    Lucy

    esmi

    (@esmi)

    Forum Moderator

    As an Apache module, yes.

    Great stuff, thanks for your continued help Esmi 🙂

    Bluehost confirmed I am running PHP 5.2.17 single php.ini (not fastcgi)for my hosting, i looked at the post with the link as above and the only thing that could apply to me was the tweaking of the .htaccess file(never touched these before) – which i suppose is the next thing to try!

    esmi

    (@esmi)

    Forum Moderator

    Did you check out the other solutions in the forum link I posted above?

    Hi Esmi, yes tried all others that supplied, just have adding things to .htaccess file left to try – will let you know if it works!!! Thanks very much again, Lucy

    esmi

    (@esmi)

    Forum Moderator

    If you continue to have problems, ask your hosts to look into the mod_security configuration on your server.

    Ah thanks, I’ll actually do this first before touching the .htaccess file myself – probably safer! Thanks again

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘HTTP errors, IO errors, and Operation time-outs when uploading images’ is closed to new replies.