Support » Fixing WordPress » Http error when uploading photos.

  • I have read about this error now on numerous forums and just can’t seem to resolve the issue.

    When trying to upload an image the image uploads but freezes during “crunching” and then a red http error appears. When I go to the gallery and view the uploaded image its size is 0 x 0 and I am unable to change any of the sizing preferences.

    The part that confuses me is that this error does not occur if I upload a screen shot on my mac or a picture taken in photo booth on osX. This makes me think that something in the metadata of normal photos taken with a camera is conflicting in someway with the wordpress site/uploader.

    I really am new to blogging and websites so am totally learning as I go along. Any help with this would be much appreciated. The strange thing is that this doesn’t occur if using which is where we originally started before realising how limited it can be compared to so moved.

    I look forward to your responses.



Viewing 8 replies - 1 through 8 (of 8 total)
  • Image/Media Uploader problems

    Image HTTP error

    WordPress Image Upload HTTP Error

    I am inserting this in every open query on this topic, as it actually solved the problem. This happens because one of the databases gets locked. You have to use PHPMyAdmin tool (available from your host most likely) to review the status of all the databases in use for your site. Select the ‘wordpressblog’ (or whatever set of databases seem appropriate) from the list at left. This brings up all the databases running on your site. The particular database that caused this problem was wp_postmeta – the status in the PHPMyAdmin window was ‘in use,’ and as our databases are small this should never be the case when you can look at them and see them in use – they should be just sitting there. Here it was locked. In the PHP MYAdmin tool, check the particular database that’s in use, then on the drop down box at the bottom select ‘repair table.’ This instantly solved my problem. Thanks to yahoo support rep!

    Guys I’ve been struggling all day with this same problem. I fixed it magically by making sure my uploads folder was 777. Then I uploaded a 2×2 pixel jpg into my post and it worked. After that it started uploading my images like a charm. Go figure.

    Has anyone found a better solution than removing the flash uploader??

    Doug-O The method you found may have worked for you but not for me, none of the tables on my database are locked or in use and still I suffer from the the dreaded HTTP error!

    Giving the world read, write and execute access to my image folder by allowing 777 privileges is not the way I am going to go as this was all working perfectly until recently.

    Anyone else have any suggestions??

    Having the same issues. My host provider is looking into it but I have to resize pics to a smaller file in the meantime.

    I host my sites on Site5 and have had great customer service for the past few years. Databases as suggested here were all ok. Issues might depend on the provider. I asked them for details and will post once received.

    The only thing I did recently was a WP update and believe the issue is in there.

    I’m receiving the same error on various WP installs. I deleted various plugins that I though might have had something to do with the issue, however, no success. Both the installs are on the same hosting service and are single installs and network installs.

    My upload limit is about 2Mb and the size of the images in question are +/- 350Kb. This issue began today – so I cannot say for sure if this is a core problem or a server configuration error.

    @esmi, I tried Otto’s solution, however, that didn’t work in my instance. I also tried Chewie’s fixes but that didn’t work either.

    I wont set permissions to 777 as that can be security vulnerability and also because this is something that needs to work out of the box, so to speak. I will keep researching, hopefully if it’s a core bug, then it can be resolved rather quickly.

    Either way, this is interesting….

    Update: The problem persists on my Win7 install, however, I tried to reproduce the error in Ubuntu 12.04 and uploading works. So, it seems like it’s a client side issue with me.

    This doesn’t work for me either.
    I tried changing the CHMOD’s.
    I tried the code in the .htaccess
    I tried disabling all add-ons.

    Nothing is working.
    Next steps.
    Get an add-on uploader.
    Re-install from scratch.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Http error when uploading photos.’ is closed to new replies.