Support » Fixing WordPress » HTTP error when uploading MP3 with Flash Media Uploader

  • Resolved Daniel Bachhuber

    (@danielbachhuber)


    Hand Built

    Hello,
    We’re getting a “HTTP Error” when using the Flash Media Uploader to upload MP3 files, but don’t get the error for JPG, txt, PNG, or PDF. I tried the mod_security rules as suggested by other threads, but they didn’t have any effect. Anyone run into this before, or have suggestions for what we should try next?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Daniel Bachhuber

    (@danielbachhuber)

    Hand Built

    We’ve made a bit of progress. As it turns out, the error is related to the size of the files, not the type. The MP3 file I was uploading was about 7 MB.

    I think it’s also relevant to note that we recently disabled SuPHP. Uploading worked fine when it was enabled, but we’ve had to disable it for performance issues.

    Daniel Bachhuber

    (@danielbachhuber)

    Hand Built

    It took me too long, but I finally figured this out. nginx was rejecting files over a given file size.

    We’re on Slicehost and have nginx running in front of Apache to serve media files. I knew all of my file size settings were correct in Apache and PHP but, as it turns out, nginx limits POST requests to something like 1 MB unless you explicitly specify otherwise in the conf file. There’s a nice thread that shows you what to add and where. Adding this and restarting nginx solved our problem perfectly.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘HTTP error when uploading MP3 with Flash Media Uploader’ is closed to new replies.