Support » Fixing WordPress » HTTP Error. when uploading images

  • Donna1923

    (@donna1923)


    I keep getting the Error message HTTP Error come up when I try to upload images. Sometimes they will upload if I resize them but this only works occasionally. It might take one image of a certain size and then kick out the next one even though it is the same size. I am at a loss as to what to do.

    I have already been in touch with the host any they can’t find a problem and say it is a wordpress issue.

    Can anyone help?

Viewing 15 replies - 1 through 15 (of 75 total)
  • Ahir Hemant

    (@hemant-ahir)

    Put this is your themes function.php
    first solution1:

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );

    function change_graphic_lib($array) {
    return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );
    }
    ============ OR ========
    Second Solution
    or may be issues with:
    The issue was related to my server configuration not having the proper amount of memory allocated to Apache/PHP.

    If anyone has this same problem, please try verifying that you have enough (64MB+) server memory allocated to Apache/PHP in your server configuration settings.
    You can also add this to your wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’64MB’);

    Third solution:
    Connect to your website using the FTP client and then go to /wp-content/ directory. There you will see /uploads/ folder. Right click on the uploads directory and give file permission 755.

    let me know if among three of not working

    cgreenleaf

    (@cgreenleaf)

    Solution 1 Worked! Thanks dudes.

    Donna1923

    (@donna1923)

    I’m very new to all this. Could you point me in the direction of where I need to go on the site to make these changes.

    Thanks in advance.

    javawpscript

    (@javawpscript)

    Through FTP. In like a client such as FileZilla or even use one that is online.

    I was having the same problem and I added the code you suggested to my child theme function.php and it worked. Thank you!

    What I don’t understand is why this problem started. I haven’t updated the theme or any plugins in the last few weeks. It was working yesterday and broke today.

    This HTTP Error began with WordPress 4.5 for me.

    The first solution in Ahir’s post resolved the problem for me.

    Same here. The “http error.” while trying to upload images (no matter how big or small!) issue began for me after updating to WP 4.5. I disabled all plugins, switched to a default theme, but nothing worked until I found this thread and tried Ahir’s first solution. Thank you for that fix!

    Thx for the solution 1, it worked great, my problem was after updating to 4.5 version too.

    Ditto for me too. Solution 1 worked. Problem started with upgrade to WP 4.5 too. This is the second problem I’ve encountered with the upgrade. The other has to do with a JQuery problem where images are no longer shown on a website. I found another fix for the functions.php file for that. I’ve never had such major problems with a WP upgrade before. It’s like everything is breaking.

    I had the same problem after updating to WP 4.5 and solution 1 worked for me. Thank you!

    Can I simply paste this at the bottom of my theme’s function.php?

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );

    function change_graphic_lib($array) {
    return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );
    }

    Hey Everyone I tried adding that to my themes function.php file and I am still seeing the error. I am using Salient.

    My host provider gave me this line to add to the .htaccess file. Either of these solutions work to resolve this error for me.

    SetEnv MAGICK_THREAD_LIMIT 1

    THANK YOU SIR!!!
    Solution 1 worked perfect, solved the http error for wp 4.5.

    Everyone try this plugin.. It worked for me. It just sets your wordpress to use the GD editor. https://www.dropbox.com/s/ckzvzgu4hh1ais9/default-to-gd-master.zip?dl=0

    My hosting company suggested this fix and it seems to have worked

Viewing 15 replies - 1 through 15 (of 75 total)
  • The topic ‘HTTP Error. when uploading images’ is closed to new replies.