Support » Fixing WordPress » HTTP Error using Image Uploader (WP 3.1/3.2)

  • Resolved hiccoughs

    (@hiccoughs)


    I know there have been tons of Image Upload HTTP error posts but I’ve noticed they’re all for WP versions under 3.0. I decided to make a new one because it has gotten confusing to swim through all the solutions and threads.

    Problem:
    – Gets HTTP error when uploading image files bigger than 200kb.
    – Upload percent goes all the way to 100% and to “Crunching…”
    – Flash uploader says “HTTP error”
    – Browser uploader opens page that says “Internal Server Error”
    – Uploader worked fine a month before prior to current situation
    – There was at one point it said “I/O error” but not appearing anymore

    The things I’ve tried that didn’t work:
    – Re-installed WP 3.1
    – Updated to WP 3.2
    – Revert back to twenty ten and twenty eleven themes
    – Disabled all plugins
    – Tried the various .htaccess solutions
    – Changed permissions to /uploads to 777
    – Recreated upload situation in Mozilla and Safari in Mac
    – Recreated upload situation in Mozilla and IE in Windows
    – Deleted /uploads and tried uploading everything again
    – Recreated images into new files then upload
    – Made an alternative folder for uploads
    – Contacted my host to see if any changes to my server

    My PHP specs:
    PHP 5.1.56, 32mb memory limit, 10mb max filesize upload
    input time: 60, execution time 30

    Help?

Viewing 15 replies - 1 through 15 (of 26 total)
  • If you are running the No SSL Flash Upload Plugin because your site uses SSL, then it causes the HTTP Error in WP 3.2, as I have just discovered.

    I assume that the WP devs patched the I/O error that was occurring before. Anyway, I hope that helps you.

    I’ve been having the same problem as hiccoughs and have also tried most of the same ‘fixes’ and am now receiving the error: Unable to create director… Is its parent directory writable by the server?

    This seems to be an ongoing issue… any other ideas??

    Having the same issue, and am gone down the same path as the fixes mentioned above.

    I can upload up to 12Mb, anything larger throws HTTP Error or 500 Error.

    Is this a common error for 3.1/3.2?

    Hey there,

    Are there already any solutions for this problem please?
    Unfortunately I got the same problem now with my new system!
    fyi:
    – WP Version 3.2.1
    – PHP Version 5.2.9
    – upload_max_filesize = 20 M
    – post_max_size = 10 M
    – uploads-folder CHMOD 777
    – mysql Client API version 5.0.45

    Any suggestions please?
    Would be nice, if someone could help please!

    I have the same problem, on a local dev site on XAMPP.
    WP3.2.1
    Latest XAMPP
    I get it on one site only, I have other sites on my local dev – they can upload.
    Happens in all browsers
    Tried all solutions above, still get the HTTP error.
    Browser uploader works fine, only flash uploadr gives this error.

    Issue fixed after checking with web hosting setting.

    “Found the problem, basically the wordpress plugin triggered the mod security.

    Access denied with code 406 (phase 2). Pattern match “^Shockwave Flash” at REQUEST_HEADERS:User-Agent. [file “/usr/local/apache/conf/modsec2.user.conf”] [line “203”]

    I have bypass the shockwave security.”

    So you may check with your hosting provider to change that setting.

    Hope it work for you!

    Hey ideaonly,

    Your post brought me the answer.
    I just had a look in the .htaccess file in my root-folder of my webspace.
    In there was written the following:

    #<IfModule mod_security.c>
    #<Files async-upload.php>
    #SecFilterEngine Off
    #SecFilterScanPOST Off
    #</Files>
    #</IfModule>

    So then I un-commented or activated the text to the following:
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    And now I can upload images without any problems and errors.

    Best regards, Alex

    @hockeyfreak, hope your steps also work for other bloggers 🙂

    Well, that .htaccess didn’t solve it for me 🙁
    I tried to use these .htaccess rules, but no use.
    I also do not use the mod.sec.
    My issue occurs on a localhost dev environement using XAMPP.
    I tried all the fixes, but no matter what I do, I still get that HTTP Error message.
    Any other ideas?

    Thanks,
    Maor

    hi. so i talked to my host. it had something to do with the server. they upgraded my server and i can upload normally now.

    @maorb, have you tried other php environment, like wamp?

    @ideaonly, I haven’t tried WAMP or other local env, but this issue is happening only in one local site, and in others it is ok.
    I thought it is something in the WP installation/plugins/theme – so I reinstalled WP and created a new local domain for it, also disabled all plugins. Then it worked fine for one time, and the next time the issue came back. It is very weird…

    I have another thread on this opened som time ago:
    http://wordpress.org/support/topic/localhost-install-http-error-on-image-upload?replies=4#post-2250473

    I am using Mowes Portable to run live site on localhost for testing upgrades – just like maorb with Xampp.

    And just like him, I am unable to upload – both upoladers!

    There seems to be some sort of location mismatch, so the files are unable to be saved, and thus the failed upload.

    My environment is running on Win7 x64, btw.

    I’m happy to see there are more with the same issue, so perhaps someone comes along with a solution…?

    What’s with the “link” button here anyway? It doesn’t work!

    esmi

    (@esmi)

    Forum Moderator

    Yes it does. Enter your text, highlight it, enter the link url and select OK. Bare urls are turned into links automatically.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘HTTP Error using Image Uploader (WP 3.1/3.2)’ is closed to new replies.