Support » Fixing WordPress » Http Error on upload.

  • First off I think this may have something to do with the plug-in WP-Post Thumbnail. That thing is really buggy but is part of the premium theme I have called “GameNOW” from

    It is kind of random when I am uploading. I will choose a file with the flash uploader and after the upload gets to 100% and starts to crunch “Http error.” appears above the form. If I try to upload with the non-flash uploader it will just go to a blank screen after I hit the “Upload” button.

    Now if I go to my media library the files will be there. Sometimes their sizes appear at 0x0 sometimes not.

    I tried deactivating the plug-in that is suspect and even manually removing the rows in the wp_options table through phpMyAdmin. Still getting the error. I am concerned that it has edited a file having to do with my upload settings and don’t know where to look.

    Uploading worked fine before this plug-in and I have even tried uploading on my 3.0 beta site (on the same server) and it works fine, so that rules out server problems.

    I have tried googling the Http Error problem and it seems it used to be a big thing when wp2.5 came out but none of their solutions have helped me thus far. Also, when using firebug on firefox some random error pops up (not on a computer where I can copy paste it) but even after thoroughly researching that error it has something to do with the Flex service of flash and nothing helped me out there.

    Is there anyway to reset my upload settings file or anything like that without doing a fresh install?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Also, any solutions give to edit the .htaccess have not helped. Nor do I think it has anything to do with my servers PHP memory not being high enough (How do I verify this?).



    One more update.

    I have just now deleted my wp-admin and wp-includes folders and uploaded fresh versions and the problem still persists.


    Check with these options:

    – Assign 755 recursive permissions to wp-content directory with the help of your web hosting service provider.

    – Add this code in htaccess of your blog/site:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off


    Shane G.

    As I said in the post above, which you must have skipped over, any .htaccess edits have not remedied my problem.

    My wp-contents folder has the 755 permissions on it.

    Any other solutions?



    I am having the same trouble you are having, also I have already tried everything you stated above. I have gone to the hosting provider and asked for their help. They so far have increased the memory_limit value. They said that it doesn’t solve for really huge files, but they didn’t clarify what they mean by a huge file, but I let them know that the user is trying to upload around 50M file. So, my only suggestion is to ask your host provider’s help desk for help. Maybe between both of our host providers and this forum you started, we might find a solution.


    Ok, so talk to your host provider and have them increase the memory_limit value. I do not know if you actually added this to the system file .htaccess.

    You said you tried everything, but the host provider change and the change below helped with 50M of upload using the flash uploader.

    add this to the .htaccess:
    php_value max_execution_time 1800

    The combination of these changes helped the problem that I was having, which also seems very similar or even the exact problem you are having.

    Hope this helps,


    Damen, I was experiencing this issue with a wp site I had installed within an existing wordpress directory By chance I looked at what pluigins I had installed and WP was activated. I deactivated this and all is fine now.


    Thanks rhinogrady…that was the perfect fix for me. Thanks for sharing!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Http Error on upload.’ is closed to new replies.