Support » Alpha/Beta/RC » HTTP Error on upload – 3.1RC3

Viewing 15 replies - 1 through 15 (of 16 total)
  • I already installed a plugin for that and it didn’t help. I didn’t have this issue when the install was still at 3.0.4 (or earlier).

    Hmm.. this is odd, apparently it’s the flash uploader but that worked in 3.0.4 without any problems..

    I have exactly the same issue and it’s driving me spare!
    I am running WP3.05 and I have the site at home on a windows machine running wampserver. Here the uploads work fine.
    However – on the webhost I get HTTP error using the flash uploader or Internal Server Error – The server encountered an internal error or misconfiguration and was unable to complete your request……
    It uploads files below 130kB fine but rejects anything above about 200kB.
    – I’ve increased ‘post_max_size’ and ‘upload_max_filesize’ to 16M in php.ini
    – I’ve increased memory allocated to php via the wp-config.php file by adding define('WP_MEMORY_LIMIT', '256M');
    – I’ve added an “.htaccess” file to the wp-admin folder with this code

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    – I’ve read that suhosin security software may be the problem but have no access to change it!
    Aaaaargh! Any suggestions?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It uploads files below 130kB fine but rejects anything above about 200kB.

    What’s the PHP file size limit?

    Hi Ipstenu
    The php file limit is miles big enough (16MB in php.ini) and the WordPress upload page reports it as such!
    We have now also ruled out suhosin as the webhost “switched this off” entirely and it made absolutely no difference.
    I’m leaning towards it being an issue in which the upload and wp-cache are somehow clashing. Although switching wp-cache off doesn’t solve the issue there seems to be something called a mutex.lock in the cache that I think WP temporarily directs the upload to so maybe I need to work out how to clear that.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Are you using wp-super-cache or some other caching plugin? wp-cache is way old and shouldn’t be used, but IIRC it needs a lot of manually wrangling to uninstall.

    Mutex lock sounds really familiar…

    OK IT sounds like wp-cache has to go.
    This is a site the maintenance of which I ‘inherited’ where both the version of WP and all the plugins were pre-historic. It’s a non-profit site but gets over a million hits/month and so we can’t really let it go down.
    The error message was
    Warning: fopen(/usr/local/www/d_admin/ [function.fopen]: failed to open stream: Permission denied in /usr/local/www/d_admin/ on line 96 Dismiss “Image_by_Ozyman_0C.jpg” has failed to upload due to an error The uploaded file could not be moved to /usr/local/www/d_admin/

    Any suggestions welcome! I’ve basic html css and php but am not really a WordPress expert.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    WP Cache is WAY old. Either use WP-Super-Cache or W3-Total-Cache for cahcing. I’ve used both to great effect. The only reason I use W3TC right now is that it behaves better with BuddyPress.

    I use supercache same issue…

    Eventually got it sorted. It transpires that the web-host had – for some reason best known to himself – changed maxrequestlen in apache mod_fcgi from its default setting of 1GB to 131k. No don’t ask me why!!! All I know is that when he put it up to 32M everything started working again. Now – how many hours of my time did I waste trying to track that one down?

    Ok it seems that I get this error because I have authentication for my word press. It is used as a staff page and therefore when I try to upload it doesn’t work. I am running all the latest PHP and Apache on a mac 10.6.

    When I take it off, I am able to upload. Is there something i should try? I have tried everything. Any suggestions?

    WordPress 3.1 is no longer in beta. Please try posting in the HowTo forum.

    MaxRequestLen was exactly what I had to change to fix this issue for me!

    Same issue,Anyone can help?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘HTTP Error on upload – 3.1RC3’ is closed to new replies.