Support » Fixing WordPress » HTTP Error on Media Upload (WP 3.9)

  • Resolved Stevish

    (@stevish)


    Whenever I upload a file using the uploader (whether flash or regular, from a ost or from the media page) it gives me the error “HTTP Error”. The original file is actually uploaded successfully, but it is not crunched.

    I’ve tried…

    • Conneting via a VPN (The network I’m on is restricted in some ways so that’s a common source of problems for me… but not this time)
    • Using another WordPress install (It works fine on other installs of 3.9)
    • Disabling all plugins/using 2014 theme
    • Re-uploading core WP files
    • Checking for common issues with my host (They are running suphp)
    • Uploading a tiny image (1kb, still didn’t work)
    • two .htaccess “fixes” `<IfModule mod_fcgid.c>
      MaxRequestLen 15728640
      </IfModule>
      <IfModule mod_security.c>
      <Files async-upload.php>
      SecFilterEngine Off
      SecFilterScanPOST Off
      </Files>
      </IfModule>`
    • Tried it in IE
    • Spitting in the back and kicking it

    Nothing seemed to work. Still get the same error with the same results. I’m using Windows 7, chrome 34.0.1847.116 m (and IE 11.0.9600.17041), though it seems like it’s an issue on the back-end rather than anything that would be affected by my OS and browser.

    Any ideas? I’m sure this isn’t a unique problem, but I can’t seem to find any solutions that work for me.

    PS. This worked fine before I updated to 3.9

Viewing 8 replies - 31 through 38 (of 38 total)
  • I had the same problem, but it ended up being a different solution:

    Uploaded a batch of images, but two errored out. Turns out they were the ones with an apostrophe ( ‘ ) in the file name. I deleted the apostrophes, and they uploaded without a problem.

    I have a client that has this issue also. We’ve tested a lot of different things, but so far nothing is working. We did find out that me uploading (Im on a Mac) works just fine, I never have these errors, yet they always have the problem (on a PC) they tried it on a Mac and it worked just fine. We’re going to keep troubleshooting and if I figure anything else out I will post another message.

    The plugin mentioned above fixed the issue for me. Thanks!

    abcjamrecords

    (@abcjamrecords)

    The solution edwahrer provided fixed my issue. Thanks alot!

    onebc

    (@onebc)

    I’ve had this issue for the past 24 hours after upgrading from 4.0.x to 4.1.x. Turns out it was a very simple fix so I thought I’d post back here in case it helps anyone else.

    I was getting the same HTTP Error as discussed here and tried some of the suggestions here to no avail. However, upon investigating I discovered that the permissions on the file /wp-admin/async-upload.php were set incorrectly to 777. Upon changing the permissions to 644, the uploading worked again immediately.

    I suspect this occurred because I was using FS_DIRECT in my wp-config with 777 permissions, and therefore when the file was updated it’s permissions were changed to an admittedly poor security level.

    Thank you onebc, your solution worked for me.

    @favethemes I just wanted to let you know we were getting this error in a VPS and used your code:

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    
    function change_graphic_lib($array) {
      return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
    }

    And it fixed the problem. Thank you!

    for nginx users this may help.

    edit: /etc/nginx/nginx.conf
    change: client_max_body_size 4m;

    edit: /etc/php-fpm.d/www.conf
    change:
    php_admin_value[upload_max_filesize] = 4M
    php_admin_value[post_max_size] = 4M

    restart services
    # service nginx restart;
    # service php-fpm restart;

Viewing 8 replies - 31 through 38 (of 38 total)
  • The topic ‘HTTP Error on Media Upload (WP 3.9)’ is closed to new replies.