Support » Fixing WordPress » HTTP Error on Media Upload (WP 3.9)

  • Resolved Stevish


    Whenever I upload a file using the uploader (whether flash or regular, from a ost or from the media page) it gives me the error “HTTP Error”. The original file is actually uploaded successfully, but it is not crunched.

    I’ve tried…

    • Conneting via a VPN (The network I’m on is restricted in some ways so that’s a common source of problems for me… but not this time)
    • Using another WordPress install (It works fine on other installs of 3.9)
    • Disabling all plugins/using 2014 theme
    • Re-uploading core WP files
    • Checking for common issues with my host (They are running suphp)
    • Uploading a tiny image (1kb, still didn’t work)
    • two .htaccess “fixes” `<IfModule mod_fcgid.c>
      MaxRequestLen 15728640
      <IfModule mod_security.c>
      <Files async-upload.php>
      SecFilterEngine Off
      SecFilterScanPOST Off
    • Tried it in IE
    • Spitting in the back and kicking it

    Nothing seemed to work. Still get the same error with the same results. I’m using Windows 7, chrome 34.0.1847.116 m (and IE 11.0.9600.17041), though it seems like it’s an issue on the back-end rather than anything that would be affected by my OS and browser.

    Any ideas? I’m sure this isn’t a unique problem, but I can’t seem to find any solutions that work for me.

    PS. This worked fine before I updated to 3.9

Viewing 15 replies - 16 through 30 (of 38 total)
  • Steve is a life saver!!

    Just disabled the ImageMagick Sharpen Resized Images plugin and I could upload again 🙂 Hope it helps.

    Thanks Stevish this worked great!!!!

    This workaround didn’t work for me. My host is useless and not even answering so I tried the plugin suggested. Any attempt to upload an image file just ends in a http error.

    Thank you!! Works great

    not work

    I read the whole post in detail, install plug-in. Does not work.
    Help would be appreciated…


    Add this code in functions.php file

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    function change_graphic_lib($array) {
      return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );

    I’ve run into this problem since upgrading to 4.0 on numerous sites. It turns out that a nifty image optimization plugin from is to blame.

    So, if you’re seeing this problem and you have the Kraken plugin installed, deactivate it and see what happens.

    (and yes, I know that the standard advice is to deactivate all plugins and test, but who really does that? LOL)

    Thanks for your feedback. I will try.
    In the mean time I have size down the video (now 13Mb). The upload did work without Http Error. But when I’m watching the video I have the sound, but the image is black.
    Any suggestion?

    I have had no luck solving this problem. I have sites on 1and1, Media Temple Premium WordPress and on Rackspace Cloud and they ALL have the problem. Nothing crazy going on here and I am uploading small files (under 1MB). Hosts have been no help as well. I tried defaulting to GD. Worked for MT hosting but not on 1and1. I saw this happen a bit with v3.8 but this seems to have gotten worse since 4.0 update on my sites.

    Pulling my hair out trying to figure this out.

    Hello fishnyc22

    Do you have any idea how to solve this, I mean what to do, how to go ahead? If not in this forum, where?

    This is a very big issue…
    Hope to get further idea from the community

    We were getting “HTTP error.” and switched to the less fancy WordPress browser uploader (/wp-admin/media-new.php?browser-uploader) and got this more detailed error: Nginx: 413 Request Entity Too Large

    On our AWS instance using NGINX, we had to adjust “client_max_body_size”. in /etc/nginx/nginx.conf

    The default “client_max_body_size” on NGINX is 1MB.

    We added: client_max_body_size 10m; and restarted NGINX.

    anyone have a followup on this. i tried everything above and still cant upload anything bigger than 20k.
    on the phone with my godaddy host and they cant find anything that would have the server stop the upload.

    Hi everyone,

    I spent hours trying to find out what the issue is, turns out this was the problem (I installed CentOS 7 which uses the new apache server and fast-cgi):

    This part is basically the solution:

    HTTP.CONF used to set a value for FcgidMaxRequestLen somewhere in the neighborhood of 1gb by default, which it no longer does in newer versions. The new default is 131072 bytes. that value is overiding your value in php.ini, so you Must change this to match your settings in php_max uploads so you don’t pull your hair out.

    I hope this helps!

Viewing 15 replies - 16 through 30 (of 38 total)
  • The topic ‘HTTP Error on Media Upload (WP 3.9)’ is closed to new replies.