Support » Fixing WordPress » HTTP Error on Media Upload (WP 3.9)

  • Resolved Stevish

    (@stevish)


    Whenever I upload a file using the uploader (whether flash or regular, from a ost or from the media page) it gives me the error “HTTP Error”. The original file is actually uploaded successfully, but it is not crunched.

    I’ve tried…

    • Conneting via a VPN (The network I’m on is restricted in some ways so that’s a common source of problems for me… but not this time)
    • Using another WordPress install (It works fine on other installs of 3.9)
    • Disabling all plugins/using 2014 theme
    • Re-uploading core WP files
    • Checking for common issues with my host (They are running suphp)
    • Uploading a tiny image (1kb, still didn’t work)
    • two .htaccess “fixes” `<IfModule mod_fcgid.c>
      MaxRequestLen 15728640
      </IfModule>
      <IfModule mod_security.c>
      <Files async-upload.php>
      SecFilterEngine Off
      SecFilterScanPOST Off
      </Files>
      </IfModule>`
    • Tried it in IE
    • Spitting in the back and kicking it

    Nothing seemed to work. Still get the same error with the same results. I’m using Windows 7, chrome 34.0.1847.116 m (and IE 11.0.9600.17041), though it seems like it’s an issue on the back-end rather than anything that would be affected by my OS and browser.

    Any ideas? I’m sure this isn’t a unique problem, but I can’t seem to find any solutions that work for me.

    PS. This worked fine before I updated to 3.9

Viewing 15 replies - 1 through 15 (of 38 total)
  • Hi Stevish, I am currently facing the same issue as well. Have been trying all the methods that I found online and those that you posted. I had also contacted my host company but the technical support personnel can’t solve it as well.

    I also tried changing theme, modifying the permission of the wp-content folder to 777 as well (I had switch it back to 755 due to security issues). Still, none of these work.

    Perhaps this is a bug of WP 3.9? I don’t have any issue uploading images in the previous version, but I can’t recall exactly which version is that. I installed an older version (3.8.1) to see if it works but the same problem occur.

    I am now able to upload my 1kb picture, but not an 18kb one or bigger.

    Stevish – Check your server’s temp folder. That makes me wonder if it’s out of space.

    I am able to upload a 3kb image but not my other images that are 150kb and above.

    Just an hour ago, I contacted the support staff of my web host once again. A different staff attended to me this time and he found out the problem was due to the php version. He had updated my php version to 5.4 and everything returned to normal! Hope this works for you as well!

    P.S. I asked the staff to check if my temp folder is full but apparently it was not.

    What was your old PHP version I wonder? WP runs on 5.2 and up.

    My hosting company just fixed it by installing the “Default to GD” plugin which “Sets GD as default WP_Image_Editor class.”

    My host is running php 5.3.27

    So I guess this is resolved now

    The plugin is (currently) available here:

    https://github.com/getsource/default-to-gd

    It’s one function:

    <?php
    /*
    Plugin Name: Default to GD
    Plugin URI: http://wordpress.org/extend/plugins/default-to-gd
    Description: Sets GD as default WP_Image_Editor class.
    Author: Mike Schroder
    Version: 1.0
    Author URI: http://www.getsource.net/
    */
    
    function ms_image_editor_default_to_gd( $editors ) {
    	$gd_editor = 'WP_Image_Editor_GD';
    
    	$editors = array_diff( $editors, array( $gd_editor ) );
    	array_unshift( $editors, $gd_editor );
    
    	return $editors;
    }
    add_filter( 'wp_image_editors', 'ms_image_editor_default_to_gd' );
    ?>

    To clarify what that MEANS is that ImageMagick on your host is broken :/ Great.

    I’m getting the same since I upgraded from 3.8.2 to 3.9
    if it’s broken in the new release, there should be a bug fix release to fix it!

    ERROR IN UPLOADING PLEASE TRY BACK LATER
    (Later never comes)

    I have just installed a fresh version of 3.9.
    I have set all permissions to 777 – plugins, uploads, 2014, 04 etc.
    I have a 64MB restriction size, so size is not the problem and it was working on 3.8

    The strange thing is that it works in all my other 5 wordpress apps that have been UPGRADED. It is not working in the brand new fresh install – new database, too.

    esmi

    (@esmi)

    Forum Moderator

    This topic has been resolved. Please post your own topic.

    Who fixed it and how do I fix it? I have several installs and not one allows me to upload graphics- never problem before upgraded to newest version. Can you tell me how it resolved?
    Thanks!!

    Kathleen,

    I did nothing and it eventually worked. I don’t there was an actual resolution mentioned here.

    If it’s a new install, insure your uploads and directories underneath have writing permissions. 777

    Kathleen:

    My hosting company just fixed it by installing the “Default to GD” plugin which “Sets GD as default WP_Image_Editor class.”

    The plugin is (currently) available here:

    https://github.com/getsource/default-to-gd

    That was the fix. It was resolved by installing that plugin. If that particular fix doesn’t work in your case, search other threads or start a new one of your own. This one has been resolved.

    rasarab

    (@rasarab)

    Thanks Stev

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘HTTP Error on Media Upload (WP 3.9)’ is closed to new replies.