Support » Plugin: Jetpack by WordPress.com » HTTP Error on media upload

  • Resolved JohnP

    (@johnp)


    I have begun getting an unspecified “HTTP Error” when I try to upload photos since I upgraded to WP 4.4.1

    The images are small (under 200 KB)

    When I de-activated Jetpack Version 3.8.2 the problem resolves.

    I have since upgraded to Jetpack 3.9.0, but this hasn’t fixed it.

    PHP Version is 5.3.6
    max_execution_time is 300
    memory_limit is 128M

    Any advice / fixes would be appreciated.

    https://wordpress.org/plugins/jetpack/

Viewing 14 replies - 16 through 29 (of 29 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    This may indeed happen, as the problem appeared to be linked to your image processing libraries before. Did you have the chance to contact your hosting provider about this, as I mentioned before?

    Hi Jeremy
    My host reports that GD support is enabled on this server.

    The upload error is still happening if Jetpack is activated.

    Things work fine with Jetpack off.

    The server is an old machine running Ensim, and I am planning to upgrade when I can find the time. Perhaps this will fix the problem.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for bearing with me though this. That’s a really odd issue.

    Unfortunately, I’m afraid I’m running out of ideas on this. I also can’t reproduce the issue on my end, so it’s hard to debug.

    Can you run similar tests on another site on that server, by any chance?

    Yesterday I shifted the site to a modern cPanel server, and the error has disappeared.

    Another possible clue as to the cause of the issue is that I was advised the old server was not compatible with these upcoming changes:

    “PayPal is updating its services to require TLS 1.2 for all HTTPS connections. At this time, PayPal will also require HTTP/1.1 for all connections.”

    If others with this problem are also hosted on an older server, upgrading looks like the only solution.

    Since I’m happy now, I’m marking this topic as resolved.

    I too can attest fully to what John is talking about. When I have Jetpack activated, I cannot upload large images to the Media Library. When I deactivate it, it works just fine. This is most certainly a Jetpack issue, as I have tried every fix here, and every fix found in multiple Google searches. After everything, simply deactivating Jetpack COMPLETELY FIXES the issue. It’s not a hosting issue because, see previous sentence.

    I am now deactivating JP to upload my images, and reactivating when I’m done. Obviously, this isn’t optimal. I’m sure JP devs would like to resolve this. Please advise. Thanks.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @bcm924 Could you run through all the tests I mentioned above, so we can find out more about the issue? This should give us more details:
    https://wordpress.org/support/topic/http-error-on-media-upload-7?replies=21&view=all#post-7916709

    You can post the results in your own thread, as per the Forum Welcome.

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

    Hi There,
    I’ve been having the same issues with “HTTP error” I’m very new to wordpress, and started working on a website yesterday. I was able to upload images earlier today, but when I went to delete 2 images from my library and re-upload 2 other images it gave me the error message, I tried “browser uploader” but that gives me another error message.

    My website is a day old and doesn’t have many plugins that can be interfering, but I’ve tried deactivating some of them, it still doesn’t work.

    Has anybody when able to solve this problem?

    Thank you

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @chrissyandsara Could you follow the instructions here?
    https://wordpress.org/support/topic/25-imagemedia-uploader-problems?replies=1&view=all

    If none of this helps, could you please start your own thread, as per the Forum Welcome, with as many details as possible about the issue, the errors you get, your site setup, and the things you’ve tried until now?
    https://wordpress.org/support/forum/how-to-and-troubleshooting

    Thank you!

    Jeremy,

    I’ve followed much of the directions shown in your link. I’m getting the HTTP error on image uploads on two different machines and websites. The errors started around the same day. I’ve tried turning off all plugins, updating wordpress, updating flash, decreasing the size of the photos, turning off my Norton firewall and clearing cache, nothing is working. My photography website needs images. Any help would be greatly appreciated.

    Thank you. http://www.stuartmeade.com

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @hoosierstu As I mentioned above, could you please start your own thread, as per the Forum Welcome, with as many details as possible about the issue, the errors you get, your site setup, and the things you’ve tried until now?
    https://wordpress.org/support/forum/how-to-and-troubleshooting

    Thank you!

    Hi Folks,

    I have been having this issue too for all my WordPress sites. Based on the discussion and troubleshooting with my hosting provider i have the steps they took to sort out this issue.

    Correcting the HTTP Upload Error

    Log into your cPanel dashboard.
    Using the file manager, navigate to your WordPress site’s root directory.
    Locate and open the .htaccess file for editing.
    Add the following line of code at the top of the file:
    SetEnv MAGICK_THREAD_LIMIT 1
    Save the changes to the .htaccess file.

    Check out the solution with Inmotionhosting

    Let me know if this works , it should .

    Confirming krazysage solution worked for me. On Hostmonster hosting.

    Thank you krazysage!

    D

    I am having the same problem, but when I open the File Manager and search for the .htaccess file, I supposedly have 3 versions of it. One in /Public_Html, one in wp_content/plugins/akismet, and one in /wp_includes. However, I don’t actually see any files with that name. I see all sorts of .php files, but the only one that seems to come close (because of the word magick) is /wp_includes/class-wp-image-editor-imagick.php

    Does that refer to a plugin somewhere or could my cpanel with WP on it be different because I am using GoDaddy for hosting? For more info on what I’ve already tried, I started a new thread at https://wordpress.org/support/topic/media-upload-not-working-http-error?replies=2#post-8579245

    Any help would be appreciated!

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘HTTP Error on media upload’ is closed to new replies.