Support » Plugin: Jetpack by WordPress.com » HTTP Error on media upload

  • Resolved JohnP

    (@johnp)



    I have begun getting an unspecified “HTTP Error” when I try to upload photos since I upgraded to WP 4.4.1

    The images are small (under 200 KB)

    When I de-activated Jetpack Version 3.8.2 the problem resolves.

    I have since upgraded to Jetpack 3.9.0, but this hasn’t fixed it.

    PHP Version is 5.3.6
    max_execution_time is 300
    memory_limit is 128M

    Any advice / fixes would be appreciated.

    https://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    While some of Jetpack’s modules allow you to customize the look of the images on your site (Carousel, Tiled Galleries, and slideshows for example), the plugin doesn’t control or change how images are uploaded in your dashboard. That’s handled by WordPress itself.

    You can read more about this common WordPress issue here:
    https://wordpress.org/support/topic/25-imagemedia-uploader-problems

    Could you go through the steps described there, and let me know if you find the source of the problem?

    If none of this seems to help, could you add the following to your site’s wp-config.php file, then try to upload an image, and check the wp-content/debug.log file for errors?

    define('WP_DEBUG', true);
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define('WP_DEBUG_DISPLAY', false);
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }

    Once you have an error, you can replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Let me know what you find.

    Sorry for the delay – I’m travelling and internet is only available sporadically.

    I’ve just updated to Jetpack 3.9.1, but the problem persists.

    I have manually replaced all the WordPress files via FTP

    Uploads work fine when Jetpack is de-activated, so I assume my settings are OK.

    Error log here: http://pastebin.com/a1CxbwM2

    You will see my images get sent to a Amazon bucket, and are accessed via am “assets” subdomain.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    All the errors reported in that file are related to the plugin you use to sideload your images to Amazon S3. Could you try to deactivate that plugin, and see if it helps?

    I know Amazon S3 for WordPress is a rather old plugin, so de-activating it was the first thing I tried. However, I still get the HTTP error if Jetpack is activated.

    I have also discovered that some (but not all) of the thumbnails displayed by the [gallery] shortcode had disappeared – I think after removing then replacing Jetpack. When I deactivated the Photon module they started to display again.

    I can live without Photon, but I would like to keep using some of the other Jetpack features.

    I am having the exact same problem for all my clients, and every wordpress developer I know is experiencing this problem.

    Let us know when there is a resolution.
    Thanks much

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I know Amazon S3 for WordPress is a rather old plugin, so de-activating it was the first thing I tried. However, I still get the HTTP error if Jetpack is activated.

    Thanks for giving it a try. When removing all errors generated by the Amazon plugin from the log you sent above, I’m left with only one error:

    [23-Jan-2016 00:08:28] PHP Fatal error: Out of memory (allocated 41418752) (tried to allocate 3072 bytes) in /var/www/html/wp-includes/media.php on line 2743

    Could you enable this plugin and let me know the amount of memory allocated to PHP on your site?
    https://wordpress.org/plugins/wp-memory-usage/

    It might indeed be different from the memory available on your server, but that’s something you could then fix by following the instructions here:
    https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Let me know how it goes.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @mcgrafx Could you follow the instructions I posted earlier on this thread, and in my post above, and let me know what you find?

    Thanks!

    When I activated wp-memory-usage I saw in the dashboard:

    PHP Version : 5.3.6 / 32Bit OS
    Memory limit : 128 MB
    Memory usage : 35.25 MB

    I tried uploading a photo with Jetpack activated and got the HTTP error message – then in the footer of the edit post page I see:

    Memory : 35.71 of 128 Version 4.4.1

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting. None of the above shows any memory issue on your site.

    Do you still get an Out of memory error when enabling WP_DEBUG again, and keeping the Amazon S3 plugin disabled?

    With the Amazon S3 plugin disabled, I just get the single line error message about out of memory:
    [28-Jan-2016 03:51:38] PHP Fatal error: Out of memory (allocated 41418752) (tried to allocate 3072 bytes) in /var/www/html/wp-includes/media.php on line 2743

    In the footer, the memory-usage plugin produces:
    Memory : 35.61 of 128

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you try pasting the following in your theme’s functions.php file, or in a functionality plugin, and let me know if it helps?

    add_filter( 'jetpack_just_in_time_msgs', '__return_false', 99 );

    Thanks!

    No, it didn’t help.
    Same message in the error log:
    [28-Jan-2016 20:21:19] PHP Fatal error: Out of memory (allocated 41418752) (tried to allocate 3072 bytes) in /var/www/html/wp-includes/media.php on line 2743

    Fatal error: Out of memory (allocated 91750400) (tried to allocate 4488 bytes) in docs/wp-includes/media.php on line 2743

    same problem here, though i never had a jetpack plugin 🙁

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you contact your hosting provider, and ask them to make sure the GD library is properly installed and running on your server?

    Let me know how it goes.

    I am still having this problem, even though I have updated to Jetpack version 3.9.6.

    I have made a discovery which might give a clue – if I open the image in GIMP and use the option to “overwrite” (without any processing), the image uploads fine.

    This has just worked on photos from three different cameras.

    I had re-sized some of the photos with GIMP using a batch processing plug-in, but uploading these files still produces an http error. When I opened them individually and overwrote them, they uploaded without problem.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘HTTP Error on media upload’ is closed to new replies.