Support » How-To and Troubleshooting » HTTP error on media upload

HTTP error on media upload

  • Since updating Flash yesterday I am unable to upload images to my site, whether I use the Flash uploader or Browser one. With Flash, it just says “HTTP error”, and with the browser upload there is a longer message:
    “Request Entity too large
    The requested resource
    does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.”

    I am trying to upload a JPG that is about 200 kb in size (and am doing it just like I have before, and it’s always worked). And there should be plenty of room for that on my host. Does anyone know if this is to do with the Flash update, or something else? Grateful for any tips about how to sort it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Nobody? Is there a problem with the WP file media-upload.php since the latest update? Anyone?


    Have you checked your php.ini to see what the maximum upload and post sizes are set to?


    You could also check these using phpinfo().



    Thanks for the info, although it seems unlikely that the setting should have changed since I last posted images (and I have posted larger ones before), but I will keep this in mind when I speak to my provider.
    As I haven’t changed any settings, to me it must be either something to do with WP (latest update?) or my provider.

    It’s very annoying, as it’s still not working.

    Thanks for your input.

    You could also download WordPress and overwrite the core files again just to be sure that none of them are corrupt.

    Same problem here, only tiny files can be uploaded (~50kb) while still small files (~150kb) fail. One day ago this didn’t happen, and it was no wp upgrade in between. I’m waiting for a response from the hosting company. (I actually just posted this so I could be Notified of a follow-up post, as I can’t subscribe if I haven’t been posting)




    Just to say for my part, it was a problem with my hosting company which has now been resolved. They had made some security improvements, which cause the WP upload problem, but they fixed it as soon as I reported it.

    In my case it was a faulty Apache config declaration, the sysadmin said.


    could you please guys provide more information on how you fixed the issue ?


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘HTTP error on media upload’ is closed to new replies.