Support » Fixing WordPress » HTTP Error on image upload to media library

  • I intermittently get an HTTP error when trying to upload images to my media library. Previously, it appeared as though restarting my router would heal the problem, but not today.

    I’m actually running 2 websites from this workstation, both using the same theme. As a test, I uploaded a test jpg (319K) to the media library to site A — no problem. Then tried the same thing to site B — HTTP error.

    Any suggestions anyone?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello Frank1crayon,

    There have been many posts on this issue and the problem varies. As a start, please make sure to review this earlier post in the WordPress Support forums as it provides possible solutions to the issue.

    Regards,
    Arnel C.

    I deactivated Jetpack, but the problem persists. I’ve cleared my browser cache and restarted the browser to no avail. On the advice of GoDaddy, I switched browsers from Chrome to Firefox. Still no good. I’m not sure exactly what, in that earlier post that’s mentioned, applies to me. I have to admit, I’m getting a little frustrated. Isn’t this platform supposed to be “user-friendly?”

    I found the problem! It’s the plug-in WP Photo Seller that’s causing the problem. I can upload images when I deactivate it. I guess I need to take it up with them.

    Thanks for the help.

    Frank

    Hey,
    I had an issue too and found out that my share host was running php version 5.5.36 and the new WordPress requires php 5.6. I had to add ”AddHandler application/x-httpd-php56 .php” to the .htaccess file to get the server to run php 5.6

    I hope this helps

    Could someone please advise? I have been able to upload images for the past few years. Today, I am trying to upload images and I keep getting an error: http error.

    Not sure what has changed … I am not a computer programmer – just a marketing person trying to keep the company’s website updated.

    Thanks!

    i am using a shared server, i can see files in my directory, resized and renamed files converted from the file i attempted to upload, they just don’t show in my media library. i updated my theme, and wordpress to the latest version. the php version is not something i have control over.

    image grabs are here: http://lapointcomm.com/httperror/

    i got this on clean fresh installation on twenty seventeen and found that in sentence “Suggested image dimensions: 2000 × 1200” – shown in upload screen, the word “suggested” actually means “ordered maximum” – height must be under 1200 AND width must be under 2000. So, 1600x 1210, but also 2200 x 1000 pictures produce this error…

    • This reply was modified 1 year, 5 months ago by  travelitaeu.

    We were already very disappointed because we could not upload any images more. Tried lots of suggestions in all these forums …

    and actually in the end the problem was simple: The wifi internet connection was too slow. We connected to our hotspot instead and it worked immediately. This might not be the solution in all cases, but give it a try, if you are facing this issue 🙂

    This problem pops up every once in a while for me. Usually a browser or computer restart will fix it, but not this last time. It’s beyond frustrating. I deactivated NextGEN, Jetpack, and Envira, but the problem persisted.

    What finally worked for me was to deactivate every single plugin with the bulk action, upload the photo, then reactivate the plugins. I have no idea which plugin(s) was/were the culprit(s), but this method saved me the time of trying one-by-one.

    Good luck!

    If you are tired of trying all the “solutions” suggested around the internet to this infuriating problem, here is a foolproof method to get your images, videos, or other accepted file types into the WordPress Media Library:

    http://www.conferencesthatwork.com/index.php/technology/2017/07/how-to-solve-the-infuriating-http-error-when-uploading-images-or-videos-to-wordpress/

    NOTE: This will NOT work if you are hosting your site for free on wordpress.org, because those plans do not allow plug-ins. Otherwise it will work!

    Version 4.8.1
    I’m also having this problem on a new clean WP install on the same server with 9 or 10 working correctly WP installs..
    also unable to select multiple images in the image library, might be related..

    screenshot of a (now) broken site:
    https://snag.gy/08Sblw.jpg

    ANY help, and a solution for this , would be greatly appreciated.

    UPDATE: I increased the php mem to 512mb and it now seems to want to work correctly.. though I shouldn’t have to set it THAT high.

    • This reply was modified 1 year, 2 months ago by  PPNSteve. Reason: updated more sites, add image
    • This reply was modified 1 year, 2 months ago by  PPNSteve. Reason: increased php mem limit to resolve
Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘HTTP Error on image upload to media library’ is closed to new replies.