Support » Fixing WordPress » HTTP Error on image upload – STILL

  • Hey everyone. I’m a relatively new WP user, and I’m running into that horrendous HTTP error on image upload. I have:

    1) read Otto42’s article:
    2) deleted my wp-admin and wp-includes folders
    3) downloaded a fresh copy of WP 2.8.2
    4) uploaded the deleted directories fresh
    5) changed permissions on my wp-content/uploads folder to 755, and then to 777 just to see if it helps
    6) ensured that my Settings-Misc “store uploads” field is set to the default.
    7) created an .htaccess file with the mod-security fix language in it and uploaded it to my domain root, the WP root, and the wp-admin directory.
    8) set the permissions for the .htaccess files above to both 755 and 777
    9) recreated the same problem in IE, FF, and Chrome.
    10) ensured that I have the latest Flash and Shockwave installed.
    11) tried uploading smaller images
    12) deleted my “uploads” folder, removed all entries from the Media Library, and tried a brand new upload.
    99) sacrificed a few chickens for good measure.

    Is there ANYTHING else that could be causing this problem?

    To throw a monkey wrench into your thought process, I have 2 blogs on 2 domains, both hosted on the same server – only 1 of them has this problem…

    I’m going insane here…

Viewing 15 replies - 1 through 15 (of 40 total)
  • Same problem here!

    All three blogs that I work on have the same issue. For the first one, it was a theme error. I added <?php wp_footer(); ?> to footer.php For the second one, it was flash. I added a swfupload_f9 file to the js folder. Both worked. Now I have the same problem with another blog and nothing seems to work! Help!

    I had the same issue although it was after I transferred my blog to a new hosting provider. Try this-
    Go to your Settings tab and then to Miscellaneous Settings. There is a place there for “Store uploads in this folder”- check to make sure that that makes sense. It should be just “wp-content/uploads”- just like it suggests. This is what was the issue for me. Hope it helps you as well.

    I have a similar problem, which occurred out of the blue about 4 weeks ago. First I got the HTTP error after the upload was “crunching”. The photo was still there I could insert it although it was full sized and I could not decrease and since “crunching” apparently did not reduce it size, it took longer to display. When inserting it, I would have to reduce it four times to get it to a reasonable size and no caption information is available. Then the flash uploader stopped allowing me to browse for the photo to upload on my computer. If I used the browser uploader, it gave me a server error. I loaded WordPress 2.8.2 yesterday and I still have the same problem, although my flash uploader will now browse my files. I inserted the security code in the htaccess file and changed the permissions to 777 with no change. Note that I get the same problem if I use a Mac or a PC and using Firefox, Safari, IE. If anyone out there has a clue how to fix this, I would be ever so grateful.

    Thread Starter jjphoto



    I could SWEAR that I’ve tried this before, but I deactivated a plugin I was using (Shared Items Post – Scheduled automatic posting of Google Reader Shared Items), and it works all-of-a-sudden!



    I had the same thing. Eventually realised my hosts were running PHP4 – changed to PHP5 and it fixed it. (Although now I’ve found that my hosts only assign 40MB of memory for PHP – which means I have to resize larger pics before upload, but at least I can upload!)



    fyankai! Thanks so much!! That was exactly what it the problem was. luckily, its just my personal blog and i had only a month of posts. So I had no clue how to go from PHP4 to PHP5, I ended up just building a new db with PHP5 and imported from the old files.




    Add this code in htaccess:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Now have a check.

    Shane G.



    I had an HTTP image issue the other day. The mod-security fix mentioned above didn’t work and the image was 24bit/16 million colors. However Otto’s note that problem could be with the image itself was spot-on. I copied the original png and re-saved it as a jpg. The image uploaded flawlessly. Since seen reports of same issue in similar images.

    So, if all else fails, try going back to the original source image, copy it and re-save in .jpg format.

    I’ve been having this same issue and finally got it fixed. Since I spent a whole day trying to get this resolved, I’m going to post the solution that finally worked for me.

    Since some of the forum posts mentioned something about their host being involved, I decided to contact my host and see if they could figure it out and they did. I asked for details about what they changed so I could post it for other users.

    Here is what they said:

    “Modsecurity was blocking the useragent of the flash uploader. This is common. I disabled the block.”

    When I asked for more details about where exactly they made this change, they said:

    “I simply removed the useragent block in /usr/local/apache/conf/modsec2.user.conf”

    Hopefully someone else will find this useful.

    If you’re getting the image upload http error during crunching, I found this to solve the problem.

    folks- take a look at this:

    it solved my problem. (i had HTTP-auth on for the directory)

    had the same problem, fixed it only when upgrade to PHP5 hope this helps !

    cosmictap‘s link solved the problem for me (after all other solutions I tried failed).

    Jon R Wilson you are my new favorite person. Worked like a charm!

    For those using 2.9 you can try this if everything else fails

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘HTTP Error on image upload – STILL’ is closed to new replies.