Support » Fixing WordPress » http error on image upload

  • Resolved kyliee


    I know that there is several threads on this topic, but I cannot seem to find a solution that works for my site.

    On image upload (using flash uploader) I get the “http error” and when I use the html uploader, I get an internal server error. With the image upload, if you refresh the browser, the image appears to have uploaded anyway, but thumbnails are not generated. If you select the image to edit, the image contains no data and the system asks to reupload.
    This happens with the 2011, 2012 themes as well as installed themes. I’ve ruled out plugins as I’ve disabled everything and still the error persists.

    I have tried increasing the PHP memory limit (128MB), various .htaccess alterations and I have contacted my host server (who will not deal with “third party” programs…ie.Wordpress).

    I’m not sure what other options to try at the moment. Does anyone have any suggestions to what has worked for them?

    I’m running WP 3.5.1
    PHP Version: 5.3.20
    MySQL Version: 5.1.68-cll
    Web Server Info: Apache
    PHP Memory Limit: 128M
    PHP Post Max Size: 64M

Viewing 3 replies - 1 through 3 (of 3 total)
  • I also just completed a clean install and am still getting this message. Anyone?

    I deduced it down to 2 things… not sure if they are correlated or not, but the first issue is with post thumbnails (featured image and crunching)… apparently adding “true” to your post thumbnail sizes in that area of your theme’s functions.php file is causing the error… if you take out true, the image will upload, however, it will not crunch to the perfect dimensions that you actually want. Hope that makes sense for that part.

    The other issue is that of the actual PHP version your hosting site is running. If you are on shared hosting, this could be a problem, because apparently (read on another post), 3.5.1 runs on an older version of PHP, so anything higher than that is going to cause an issue. The advice from the other post was “guess we’ll have to wait for 3.5.2”

    I guess the long and short of it is that 1. Those are the issues that I have found and 2. I don’t think there is an actual solution about it, and I haven’t been lucky enough to find any documentation that the good people at wordpress are aware of this issue.

    Guess we’ll just have to wait for 3.5.2 or 3.6 when it’s out of beta.

    Thanks to iammkstevens for the reply!
    After much back and forth with my host, turns out the problem was a permissions issue with the main .htaccess file. They had to solve the issue on their end.

    I highly recommend to anyone experiencing this issue is to load firebug (or Chromes inspect element) when uploading the file. I found that it was throwing a 500 internal error that wasn’t being logged in cPanel – which led to deducing that it was a server problem and not a WordPress problem.

    I hope this helps anyone else who runs into the same problem. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘http error on image upload’ is closed to new replies.