Support » Fixing WordPress » HTTP Error on image upload

  • Hey,

    To start off with, here is the link to my site: I’m not the best coder in the world, so I’m sure I’ve done something to not allow my theme to jive with the new image uploader.

    Here is my story so far…

    I uploaded an image: 1920×1200 (486kb) and it gave me a “HTTP error” message (this is also the same for other themes I’ve created)… I then went upon troubleshooting for the last several hours until I finally landed on the post thumbnail section in my functions.php being the issue (I hope and think). I wish I had a complete solution here, but I don’t, and I’m wondering if for some people if it’s a bug with their theme, or something that is messed up in WordPress 3.5.1…

    Let’s just say I did the most common sense things that are told to everyone on how to solve problems… ie deactivate/activate plugins, re-install the version of wordpress, etc. I went through and checked my javascript and jquery that I have manually installed (deleted the enques, uploaded image and got the same result as always: http error).

    I figured it’s something to do with my theme because the 2012 theme works wonderfully. Finally I deleted everything in functions.php. I then uploaded an image and it worked perfectly. From there, I went through trial and error of deleted each different section and then uploaded an image, but to no avail, still the same “http error”: jquery, navigation, sidebars, shortcodes didn’t work, until I got to post thumbnails… and this is where I am now…

    here is what my code looks like (this is what I believe causes the http error for me):

    // Featured Thumbnails
    	add_theme_support( 'post-thumbnails' );
    	set_post_thumbnail_size( 210, 210 );
    add_image_size( 'featured', 260, 260, true ); // Located on FRONT PAGE
    add_image_size( 'quicks', 160, 160, true ); // Located on FRONT PAGE

    Because when I take away the “true” in the add_image_size, everything uploads fine and no error.

    // Featured Thumbnails
    	add_theme_support( 'post-thumbnails' );
    	set_post_thumbnail_size( 210, 210 );
    add_image_size( 'featured', 260, 260 ); // Located on FRONT PAGE
    add_image_size( 'quicks', 160, 160 ); // Located on FRONT PAGE

    The solution of taking out the “true” would be fine if this was just for my site, because I don’t mind cropping images to fit properly, but I don’t expect any clients to do the same. I’d much rather them be able to upload an image of any dimension and have wordpress crop it for them… isn’t that what makes wordpress (and other CMS’ special?).

    I’m wondering if anyone else is having this issue, and if there has been any luck finding solutions. Would love to get to the bottom of this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Try same with diff theme/no plugins, this topic is now common…a change was made to the media lib, work through it by first testing your site with default theme and no plugins…

    Hey, thanks for the reply. I’ve tested it out with the 2012 theme already and the uploader works completely fine. It doesn’t seem to make a difference when I test with my theme whether or not I have plugins active… either active or deactivated I still get the “HTTP error.” I also tested out all my jquery and javascript by deleting it from my code and uploading an image, which still resulted in an HTTP error message.

    It wasn’t until I deleted the “post thumbnails” area in my functions.php file that the upload would work on my theme. Then I narrowed it down to the uploader only working when I don’t use “TRUE” as a value (so that the images crop upon crunching). So it works when I take out the “TRUE” value, but not when I have it in… which is very much needed for my other clients.

    Again, thank you for the advice and I guess I could have been a little more clear in what I’ve already done in my previous post.

    And yes, I’ve seen that this is becoming a common issue, so hopefully a solution comes shortly. If I figure anything out I’ll post it on here before I click the “resolved” button.

    UPDATE: I’ve been working on a site on my localhost using 3.5.1 and it seems like I can upload any size image I want (up to a point I’m guessing). So it is possible that the issue I’m facing is with my own hosting/servers. However, if everything worked with 3.4.2 why is picture uploading screwed up with 3.5.1? Does anyone have an update on this… and if it’s an issue with my host/server, is there anything I can do to temporarily fix this issue?

    ANOTHER UPDATE: In case anyone is coming here and reading this.

    I’ve submitted a ticked for my hosting service (HOSTPAPA) to see if it is an issue with their version of PHP, APACHE or MYSQL… their PHP and APACHE are more recent than my localhost, but their MYSQL is older… so there may be an issue there.

    For now, until there is further notice, I’ve gone back to wordpress 3.4.2 since it was the last version that worked. I’ve tested it out with my sites, and the uploader works flawlessly. I’m sure there may be some security risks involved with not having the latest version of WordPress, but I just couldn’t handle the face that 3.5.1 couldn’t crunch images properly.

    For those looking to downgrade to 3.4.2 (which I don’t know if people would recommend or not), this is the site that worked for me:

    Once I hear back from my hosting company, I’ll update again. For now, I’m going to continue to run my platforms on the most stable version of wordpress… 3.4.2.

    If anyone else has run into this issue with 3.5.1 and have solved it, please let me know.


    I’m getting an HTTP Error on all of my installs whenever I try to upload an image via Featured Image. Annoyingly, they’re all very small images.

    What’s the solution? I need a fix FAST!


    So I received an answer from my hosting today. Here is what their message said:


    We have disabled mod_security rule (350000) triggered against the domain

    I went and tested one of my slider images 960×400 and it worked perfectly… crunching all images. So that`s good news.

    However, I ran into another issue that caused either the same or another HTTP ERROR. On another site I use a massive BG Image for my posts, and the file size I upload is 1920×1200… it`s f’n big but works as an image across all platforms. Anyway, I went to upload it with the new mod_security settings and I received an HTTP ERROR.

    So for now, the small issue is taken care of, however, I’m hoping they can solve the issue with my other site. For now, I’m going to keep the other site running 3.4.2 because it’s the last install that actually worked properly for me.

    The long and short of it all: talk to your hosting and make sure it’s not something on their end. Also, make sure you test uploading images to your theme using your localhost (WAMP/MAMP/XAMP, whatever)… if everything works fine there, then definitely talk to your hosting to see what’s going on with them.

    Hope that helps… I’ll update again once I hear back from my hosting.


    Thanks for the updates.

    I’m having the same problem with the same hosting provider. I host several other sites (they work fine) with them but on different physical servers.

    Please keep posting updates as you find out more info.

    Much appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘HTTP Error on image upload’ is closed to new replies.