Support » Fixing WordPress » HTTP ERROR on image upload 3.6.1

  • Resolved cityslacker



    I have an unresolved issue when trying to upload images to my wordpress site. I have explored every avenue available on this issue from the support forums. I am seeking new advice.


Viewing 10 replies - 1 through 10 (of 10 total)
  • Can you be more descriptive? Can you give us a screenshot of the error?

    Sorry for my lack of description. I am relatively new to wp. I am trying to upload an image well within the limitations (with no previous problem) and am just recieving a HTTP error upon finishing. Here is a screenshot

    it seems you dont have permission on uploads folder or your image is not recognised format or your image size is bigger than permitted upload size.

    try this solution as if possible:
    see this

    Thanks for link, thaw was a fresh page that I havn’t seen before with new suggestions.

    However, the problem seems to have solved itself. Which is mildly irritating. The only actions my computer has ten in the last 12 hours is to run some updates. Looks like this could have been the crux of it.

    Thanks for you’re help. And seeing as this topic seems to be reoccur; I will not be closing this thread just yet.


    Andrew Nacin


    Lead Developer

    I think this is potentially

    I am having the same issue with about 10 of my WordPress sites that I’ve made for clients. Didn’t have an issue with it until around April 2013 or so. I tried Zakir’s post and it didn’t help me. Anyone have any ideas?

    I am thinking this could this be an issue on the host side, because I had an issue with on of my Drupal sites, I fixed it by updating the temporary directory from “/tmp” (which worked fine in the past) to “tmp” in the setting. Drupal problem showed up at the same time as my wordpress HTML Error for uploading media.


    Update: Error Fixed! 🙂

    After I added the memory limit to 64MB in wp-config.php

    define('WP_MEMORY_LIMIT', '64M');

    and added this to the .htaccess file

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    I waited 10 minutes and tried to upload files and everything worked perfectly!

    All of a sudden I got the error as well. I knew that my NextGen Gallery the older version before they really messed it up with the version 2,0 was the problem.

    I deactivated the plug-in and the images now upload fine. I am not sure if it is a random situation because it was working, but if you have NextGen Gallery installed, deactivate the plug-in and give it a try.

    When I am done, I will reactivate it again so my images on the site will show. I will see if this is a rare situation or something that is now broken…

    i had the same issues and i added this to my .htaccess file like the user above and it worked immediately…weird

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    I had the same issue and I tried all of the suggestions mentioned in WordPress forums, to no avail. What worked for me is changing the memory upload limit. To do this, you just need to create a document titled “php.ini” in the root directory of your website. Within that document, the following criteria needs to be listed:

    memory_limit = 512M;
    upload_max_filesize = 512M;
    post_max_size = 512M

    (you can specify what you want the upload MB limit to be – doesn’t have to be 512).

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘HTTP ERROR on image upload 3.6.1’ is closed to new replies.