Support » Fixing WordPress » HTTP error on image upload

  • When trying to add images to post, keep getting an HTTP error. I’ve tried troubleshooting by changing themes and deactivating plugins. So far nothing’s worked. I can still see the image in the post, but there’s no thumbnail visible in the gallery or anywhere in the post draft.

    This has only started happening after updating to 4.0.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p

    (@t-p)

    what theme are you using?

    Wentasi, by Fame Themes. I changed to the theme I’d been using before that had no issues, but same problem.

    Found the culprit….the Akismet plugin. So…there’s that.

    Apparently that’s not the culprit. Having the same problem again. All my plugins currently de-activated, and it’s still showing an error.

    Same problem here. Anyone have a fix?

    I’m having the exact same issue with image uploads. As suggested elsewhere, I tried the single file browser uploader and receive error message “Internal Server Error”. Web host saying it’s a WordPress issue. Causing BIG headache! Please post other possible solutions. Thanks!

    same issue.. frustrating..

    Frustrating for sure! Same problem here but hopefully solved on 4.0. I deactivated all plugins. Uploaded images. Re-activated plugins. Testing site now.

    Having the same issue, does anyone have a fix?

    SOLVED on 4.0
    Tested on 4.0, my solution above solved my issues. I can now upload images using select files or drag & drop.

    Suze thanks for the info, the fix did not work for me,

    Fix for Ngnix

    I am running on Ngnix, and this fix is only relevant to those using Ngnix

    A few days ago a security update was released on installation for me the /var/lib/nginx/tmp permissions where changed, changing these fixed part of the issue.

    I then had an error in WordPress saying: “xxx.jpg has failed to upload due to an error Missing a temporary folder.” i checked php info and no upload folder was being listed, so i updated php.ini with upload_tmp_dir =/var/tmp/ for the upload location.

    All is now working as normal.

    Let me know if this fix worked for you,

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘HTTP error on image upload’ is closed to new replies.