[resolved] HTTP Error Just Before Image is Finished Crunching to Upload (12 posts)

  1. fearnobeauty
    Posted 3 years ago #

    This problem began just a few days before I actually uploaded to WordPress 3.3.2, but it is still happening.

    I should preface this by saying I known nothing about code and really haven't understood some of the forums I have read regarding Http errors.

    Basically, when I try to upload an image (typically under 160 KB), either by multi-file uploader or by browser uploader, the image loads up to 94% to 99% then quits, and reads in red "HTTP Error."

    I have tried uploading while in different browsers: Firefox and Safari.

    I have tried going to my root directory, and editing my .htaccess file to include the following at the top:

    AddType x-mapp-php5 .php

    This did not help the problem.

    I am not really sure what else to do, and again, I really am not a code person at all. Any "layman" help is much appreciated!

    Thank you in advance.

  2. fearnobeauty
    Posted 3 years ago #

    I should also add that this comes up also when I try to use the "browser uploader":

    Operation timed out after 25001 milliseconds with 0 bytes received

  3. esmi
    Forum Moderator
    Posted 3 years ago #

  4. fearnobeauty
    Posted 3 years ago #

    Thank you for this. I input this code into my .htaccess:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Didn't work.

    I installed the no-flash-uploader - didn't work.

    I am figuring it may be an issue with my Flash Player...but I am having trouble updating it and/or uninstalling it. I get this message when I download:

    Adobe Reader could not open 'uninstall_flash_player_osx.dmg' because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded).

    I am at a loss...

    Any other ideas? :(

  5. lupi73
    Posted 3 years ago #

    You have many of plugins, which one?

  6. lupi73
    Posted 3 years ago #

    you are wp-smushit ???

  7. gajah23
    Posted 3 years ago #

    Had the same problem and now it works by deactivating Wp-Smushit plugin

  8. lupi73
    Posted 3 years ago #

    That is why I asked if the person to use the plugin wp-smushit, I made as you deactivated this plugin and the problem disappeared!

  9. fearnobeauty
    Posted 3 years ago #

    Thank you so much! I did deactivate it and it solved the problem.

    So, deactivate WP-Smushit Plugin - solves the HTTP error for image uploads.

    Thanks again.

  10. lupi73
    Posted 3 years ago #

    Delighted for you

  11. lolcaption
    Posted 3 years ago #

    WP-Smushit claim they have fixed/hidden the issue in the latest release.

    added setting to disable automatic smushing on upload (default is true)
    on HTTP error, smushing will be temporarily disabled for 6 hours

    Not sure how that fixes the issue but if you love smushing then it should make your life a bit easier.

    Edit: Found some more info. Turns out it's not the plugin but actually the Yahoo API - too many people smushing it would seem: http://wordpress.org/support/topic/plugin-wp-smushit-http-error-on-image-upload not much the developer can do :(

  12. amar0407@gmail.com
    Posted 3 years ago #

    By deactivating wp-smushit plugin it worked for.
    I had wasted my time for about one or two days and then solved by this site.

Topic Closed

This topic has been closed to new replies.

About this Topic