WordPress.org

Forums

[resolved] http error in media uploader (23 posts)

  1. studinfo
    Member
    Posted 1 year ago #

    hello, i have problem when i upload big pictures in media, it has written HTTP error. i change theme. when i used old theme , i had not this problem, but now i have. pls help me.

  2. studinfo
    Member
    Posted 1 year ago #

  3. Is this on a WordPress Multisite? Multisite does have a max file size upload settings.

    When you go into the Multisite Site Admin section, click Network Settings in the Dashboard and scroll down. There is a setting for max upload file size and Site upload space.

    If you have already have a large value there then your server is preventing the upload because it exceeded the file size limit. Are you on a shared host? You'll need to edit the relevant sections of PHP.ini.

  4. studinfo
    Member
    Posted 1 year ago #

    it is my site - studinfo.ge . i think i have problem since i upgrade wordpress 3.8

  5. Is studinfo.ge a Multisite instance of WordPress?

    Http errors like that are ... crappy. And not generally Multisite related (Multisite will tell you it's too big).

    Check your TMP folder (or ask your host to) and see if it's full. That's normally the cause. Also check your server's error logs.

    And you said you did not have the problem on an older theme, so it's POSSIBLE the new theme is conflicting with the uploader. If so, there's nothing to do but use a different theme :/

  6. studinfo
    Member
    Posted 1 year ago #

    now i think it cause of wordpress 3.8 . i have not problem with small image. when uplaod big size image, it is http error and image has only 1 wigth and high, when i change it, it fix.

  7. It's not WordPress it's your server. Yaaaaay.

    Check your TMP folder (or ask your host to) and see if it's full. That's normally the cause. Also check your server's error logs.

    Do that. I betcha that temp is full.

  8. studinfo
    Member
    Posted 1 year ago #

    thank. i have sent mail to my hosting provider ) godaddy always have some problem :S

  9. OutdoorsWriter
    Member
    Posted 1 year ago #

    It's WordPress in my case. Resize photos to less than 500 pixels wide sometimes helps. It's been a problem for thousands of users since the upgrade to 3.8.

  10. It's not WordPress.

    I mean... it is but it's not. Your problem is with LARGE images your SERVER is running out of room to manipulate it, and SOME servers aren't as good about emptying the temp folder as others :)

    It's kind of like saying the traffic jam is why you ran out of gas. It's true, but it's not the full picture.

  11. Heavy Si
    Member
    Posted 1 year ago #

    I had the same/similar problem, but when upgrading from 3.7 to 3.8. In WP 3.7, the images I had been uploading were 1000px square, and never more than 1MB. This worked fine.

    After upgrading to 3.8, the files needed to be MUCH smaller (100px square) in order to successfully upload.

    I raised the server's php.ini "memory_limit" from 32MB to 64MB and restarted Apache. This totally solved the problem. Hope this helps someone else.

  12. jpajot
    Member
    Posted 1 year ago #

    Hi,
    Never had any problem to upload large images (1500x900px always under 1MB). Since the upgrade to 3.8 I have an HTTP Error. Still no problem for small images under 800px.
    It's a problem for I was using HD Backgrounds for my pages...
    I can't change the php.ini (1&1, I know don't laugh ;)

    Any solution on the way?

  13. Andrewcb
    Member
    Posted 1 year ago #

    To those who call, "It's not wordpress" - what server issues are they, that so neatly coincide for so many, to the change of WP versions. My server (Hostpapa) tells me there is no issue (I don't believe them.)

    I don't care where the problems lie; we can't go on for weeks without solutions.
    Thanks all, for all your efforts.

  14. BackpackersUnion
    Member
    Posted 1 year ago #

    Hey everyone, I had this same problem and stumbled across a small fix that will hopefully help a few.

    I was getting the same exact error message as @studinfo 's screen shot when uploading large image files (Tested with 4.9 - 9mb files). The image would fully upload, then a few seconds later return the error. I used the "Resize Image After Upload" Plugin on one of my subdomains and when I tried uploading the images there it worked great.

    Plugin site,
    http://wordpress.org/plugins/resize-image-after-upload/

    Hope this helps.

    *For multisite users. Make sure your network settings are set to allow large file uploads. I believe fresh installs are set to a 1mb file upload limit.

    My site; WordPress 3.8.1 Multisite with BuddyPress 1.9.2.

  15. rogerstone26
    Member
    Posted 1 year ago #

    Hi BackpackersUnion

    Thanks for the plugin tip. It worked a treat for me (on a non-multisite installation)

  16. j2l
    Member
    Posted 1 year ago #

    Sorry to revive this post but this is a weird issue (I also have).
    Since I started with a fresh WP8, I can't say it was working before 8.
    I cannot even upload a 7kB without getting "HTTP error", sometimes it goes through and freeze on "crunching", and only once it went through without errors.
    No plugins involved here (everything switched off). Web server is LiteSpeed. I can't access ini and conf files.

    I dug a little bit:
    Files are in fact uploaded (visible via FTP in wp-content/uploads/2014/03 for instance).
    When trying to upload with the alternative old "browser uploader", I get a 503 error message from server, but only AFTER the file is uploaded on server.
    Thumbnails are not created or image resized (using above plugin).

    There might be a misunderstanding about upload limit:
    It is not from Site settings > Site Upload Space Quota but from Network Settings > Max upload file size (1MB by default, maybe reset at WP8 update?).

    BTW, even if the image is not processed and throw HTTP error, it is added to Library and you can still add this image to posts and see them via frontend!
    I think something bad happens between Library and thunmbnails creation :(

  17. j2l
    Member
    Posted 1 year ago #

    OK, I read more about solutions proposed here an elsewhere and installing https://github.com/getsource/default-to-gd plugin worked for me.
    I guess image magik is old on hosting and WP8 wants a recent one.

  18. MyPCHost
    Member
    Posted 6 months ago #

    I can tell you first hand - that the problem is in fact both. With the change of WP versions, updating, etc. as WELL as server settings, specifically PHP that you need to modify, or have your host modify your php settings.

    Customers that are hosted on cloudlinux operating systems generally have the ability to manipulate the versions of php (from 4.4 to 5.6, if their host has installed them all) and that includes settings, upload size, memory limit, path to the tmp folders, you name it - its there. Its easy to do so and it saves time. Especially if you're coming from another host that used a different version of PHP.

    On all my servers, I run the cloulinux with the php selector - and both on my end as the systems admin and the end user, we are all happy. When something comes up - there's no editing any .htaccess file or php.ini file - this will take care of it, along with changing versions of php on the fly. Every single customer can run a different version of php and it has no effect on the others - making it basically flawless.

    To that point - as I said, this problem stems from WP with their updates to the core, and it relies upon the server you are hosted upon. Don't make the mistake of thinking its not both, because it likely is, or at least a good possibility, but the majority of the time, its a simple setting that can be changed within PHP.

  19. mohdsh85
    Member
    Posted 5 months ago #

    Hello Guys,

    i have a strange problem, related to this post,

    i tried to upload images and its gave me http error but the images uploaded correctly to my server!!!! i can download it easily using FTP, and the images not displayed on my webpage,

    thanks for help, and i tried all permissions, seems the
    problem in database

  20. nhale
    Member
    Posted 5 months ago #

    I too am having the problem that mohdsh85 describes; after this last weekend, whenever I try to upload images using either the standard media file uploader, I get an http error, but the image file IS uploaded. No error is shown when I use the browser uploader, though the browser shows a blank page, but the file IS uploaded. No record is created for the media in the posts table and the additional versions of the image file are not created. While I can work around this, I'm trying to determine why it has suddenly started occurring in an environment where all of this has worked...

  21. patooti
    Member
    Posted 5 months ago #

    Same issue here. Files are uploaded to the directory and can be downloaded via FTP. However I receive an error message (HTTP Error) in wordpress when uploading and they don't appear in the library.

    Help?

  22. gallium77
    Member
    Posted 5 months ago #

    unchecking imagick in php extensions (cpanel) seems to have done the trick for me - thanks j2l. presumably wp then falls back on gd. hooray, this had been so frustrating!

  23. Magzen
    Member
    Posted 5 months ago #

    Thanks j2l, the imagick solved the problem for me to after trying everything else.

    The steps i took in WHM

    1.Go to "Software ┬╗Module Installers"
    2.Click on "Manage" for "PHP Pecl"
    3.Search for "Imagick"
    4.Even if Imagick shows as not installed it can still be installed, so click on install, if it is installed it will tell you it is already installed, so when you search for it again it will show as installed this time, you click on uninstall.
    5.Restart Apache

    you can even see if imagick or other modules enabled in php by creating a file call it whatever.php and include the following line in it

    <?php phpinfo(); ?>

    upload it to the root of your WP domain and enter it through your browser, it will show you in detail everything in php, hope it helps.

    credit to the people who helped me solve this on the way in the forums :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags