WordPress.org

Support

Support » How-To and Troubleshooting » HTTP Error in media upload tool

HTTP Error in media upload tool

  • Hi All,
    Is there a universal fix yet for HTTP Error that appears in the image upload tool?

    I just uploaded 2.5.1 and I thought that would eliminate the problem. Apparently I had a clean upload of 2.5.1 … or at least wp automatic upgrade said so.

    I cleaned the file out of the js cache. But I don’t want to proceed further ’til I get some advice.

    After I select and open a picture from My Pictures in the little browser box, I get a red HTTP Error message on the screen of the image tool.

    What if I just uploaded a pic to /images file? What code would I use to insert the pic in my post? The path I used was /public_html/myblog/wp-includes/images. The pic’s in there now.

    With some great help, I got all my plugins problems solved. I’m just flingin’ plugins all over the place, now.

    Gene

Viewing 6 replies - 1 through 6 (of 6 total)
  • Bumped this up ’cause I’m getting a little desperate about getting pics on my site.

    I’m totally confused about all the answers. I know they come from folks who are really trying to help, but every time I read about a fix, there seems to be more posts that it didn’t work for them.

    It’s hard to believe that a platform as prestigious as WordPress has not addressed this problem with a final fix.

    OK, I’ll just skip the image upload tool. How do I, in detail, upload images through the /images file on my server side (through ftp)?

    I’ll be forever grateful for an answer to that question.

    Gene

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

    To fix the issue you can also add the following lines to your .htaccess file;

    <IfModule mod_security.c>
    <Files async-upload.php>
     SecFilterEngine Off
     SecFilterScanPOST Off
    </Files>
    </IfModule>

    @petercoughlin Thx, this worked for me on my hostgator acct.

    Anyone know if there are security issues in adding these lines to .htaccess?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    First, these answers are in the sticky post and have been for months:
    http://wordpress.org/support/topic/164999

    Second: There’s no real security issue from that particular set of lines. It simply disables the security checks on the upload receiving part of WordPress.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘HTTP Error in media upload tool’ is closed to new replies.
Skip to toolbar