Support » Fixing WordPress » http error image upload

  • Hi!

    I get this error on every attempt to upload an image. I´ve tried several images, various browsers and different machines. The same error occurs every time…

    The tips in the sticky post do not seem to solve the problem…

    The message I get is:
    HTTP ERROR
    crunching
    An error occured in the upload. please try again later.

    What would cause such an error, and how can I resolve it?

Viewing 15 replies - 16 through 30 (of 31 total)
  • fransgaard

    (@fransgaard)

    Hi I had the same error with an older version of wordpress. From one day to the other it just stopped allowing me to upload images and I got this error:

    Unable to create directory /customers/fransgaard.eu/fr
    ansgaard.eu/httpd.www//../../../../../../../../../../..
    /../../../../../../tmp. Is its parent directory
    writable by the server?

    I thought it was the hosting company’s fault but they can’t seem to find anything on their side, so I upgrade to the latest verison of wordpress.

    This didn’t solve the problem either. I can still post but unfortunately I still cannot upload photos, the error has change to just say “HTTP ERROR” now.

    Does anybody know a solution to this?

    alony

    (@alony)

    Same problem with me. Clean install, tried doing the fixes, no change.

    Moderator Samuel Wood (Otto)

    (@otto42)

    The ../../.. thing means that you have been hacked.

    Search the forums here for that sort of thing. Restore your database from a backup if you have one.

    fransgaard

    (@fransgaard)

    hacked?

    ><

    hmmm I don’t have a backup of database, but everything I have posted up until now is still showing. Do I still need to wipe database?

    Will search the forum now. Thanks

    cperabo

    (@cperabo)

    I tried both IE6 and Firefox and have the same problem. I have used FileZilla to load the images and then just picked them from the URL. Not the cleanest, but it works… now I just have to figure out how to do Thumbnails…

    Update: it works!
    This solution worked for me:
    http://www.hongkiat.com/blog/wordpress-25-image-upload-error-wordpress-fix/

    I tried big files, small files, wide files, Firefox, IE6, Changing permissions… nothing. But changing the .htaccess code worked.

    webwisedesign

    (@webwisedesign)

    Otto, for the fixes you suggested at http://wordpress.org/support/topic/164999 what is the correct thing to do if the mod_security is causing problems?

    6. mod_security might be causing problems. Disable it to see if that is the problem.

    This worked for me but now don’t I have a security issue?

    I am having the same problem since I upgraded – or maybe not quite the same. The error I am getting is:

    From Computer
    HTTP error.

    The file I’m uploading at the moment is only 8K. The only plugins I’m running are TinyMCEAdvance, Backup WordPress, Events Calendar, WordPress Automatic Upgrade.

    The Hongkiat.com solution doesn’t work for me, and anyway, it seems like there might be security issues … Anyone have any ideas? At the moment I’m using FTP to upload images, which is a right pain!

    So, I think for the moment, as Raffo says, is to use the Nextgen Gallery. Which is fine for me because I’ll now be using this awesome plugin!

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    let me know the outcome. dave@isnigh.com

    I had the “Http error”.

    Before you waste time on all the fixes suggested, try the same upload from IE. I was using Firefox and switching to IE remedied my issue.

    That said, there seems to be a fix needed for Firefox …

    iamthechosenone, The sites we are having difficulty with are also on HostGator. Thanks for the information! It is good to know that the hosting configuration can be change to fix this issue.

    I’m still getting the http error when trying to upload media.

    I went here BUT THERE Are no instructions that I can see.

    http://trac.wordpress.org/ticket/6443

    How can we easily fix this?

    I see the htaccess suggestion above but the instructions are not
    detailed enough for a non expert, a few missing steps…

    Help please.
    Thanks
    D

    I have Same problem, too. Whats the solution?

    I use a plugin that has fixed the error for me in the past and today when I uploaded to the new version of wordpress I had to run it again. I’m now able to upload pics and whatnot without the http error. It was the quickest fix I could find.

    The plugin is called Image Upload HTTP Error Fix

    Hope it helps someone else.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘http error image upload’ is closed to new replies.