WordPress.org

Support

Support » How-To and Troubleshooting » http error image upload

http error image upload

  • Hi!

    I get this error on every attempt to upload an image. I´ve tried several images, various browsers and different machines. The same error occurs every time…

    The tips in the sticky post do not seem to solve the problem…

    The message I get is:
    HTTP ERROR
    crunching
    An error occured in the upload. please try again later.

    What would cause such an error, and how can I resolve it?

Viewing 15 replies - 1 through 15 (of 31 total)
  • I’ve got the same error happening. I just switched to 2.5 a few days ago.

    any news?

    it’s a big bug… possible that noone has fixed it??? 🙁

    super rats
    Member

    @super-rats

    It doesn’t seem to like larger files. One image was a 194k jpg and I got this error. Smaller images upload fine for me.

    simcomedia
    Member

    @simcomedia

    I have this problem also. I’ve tried tiny files and large files. Same results. Exact same error over and over on the crunching part.

    Anyone have a real idea on this issue?

    I have run into the same error, but only using Firefox. When in IE, I get a completely different error, but the image actually successfully uploads.

    Unfortunately, I cannot manipulate that file in IE, but if I switch back over to FF, it sees the image and is perfectly content to mess with it.

    This tells me that it is definitely a WP2.5 issue, and not something with folder permissions, file sizes, or config.

    I have also seen many people have this issue, but I have yet to see a solution presented that works (other than the one I use right now) either officially or unofficially.

    bpolhemus
    Member

    @bpolhemus

    Anyone tried using Safari? I don’t use Safari much despite installing it (at Apple’s insistence) on my Windows XP laptop, but it’s a though.

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Have you gone through the various fixes listed here?
    http://wordpress.org/support/topic/164999

    May want to check out my recent post on mod_security and flash

    I have tried every single one of those fixes.

    The main problem is that they actually seem to work. For instance, I put in this one a couple of days ago:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Uploads worked fine. Now today, they are no longer working. This has happened with at least half of the fixes I have tried (and all of them that have to do with .htaccess). The other half just didn’t do anything.

    The only one I haven’t tried – and have been avoiding – is the no flash uploader plugin. It seems silly to me that I have to turn off half of a feature of 2.5 just to get the rest of it to work.

    What is worse is that it appears to me that the WP folks who can fix it aren’t doing anything to fix it. Any time someone complains about this problem, people point to the same post you pointed me to, but never say “its being worked on” or point to the ticket in the bug tracker.

    From what I am seeing on this message board, this is a consistent, persistent problem across multiple installs on multiple architectures using multiple browsers. It is a real problem that tweaking .htaccess or turning off (or on) plugins is only putting a band aid on.

    I just installed a clean install and can’t upload as well. Looked all over the message boards and tried ALL solutions. Any ideas what to do next?

    webwisedesign
    Member

    @webwisedesign

    Added the .htaccess file to the wp-admin directory. The

    HTTP ERROR
    crunching
    An error occured in the upload. please try again later.

    Changed to

    Unable to create directory /home/mysite/public_html/wp-content/uploads/2008/04. Is its parent directory writable by the server?

    And, Yes, the parent directory is writable by the server (755).

    just a big BUG of wp2.5…

    hope they can solve…

    my solution, is to use nextgen gallery plugin

    fultonfence
    Member

    @fultonfence

    i had this same issue and error for uploading photos, mp3s and videos – but changing the mod_security settings solved it.

    thanks

    Blooper1a
    Member

    @blooper1a

    same issue with 2.5.1

    apply mod_security to solve the issue

    jeremycherfas
    Member

    @jeremycherfas

    Mod security did not work for me.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘http error image upload’ is closed to new replies.