Support » Fixing WordPress » HTTP Error during Picture Uploads in Version 3.3.1

Viewing 8 replies - 1 through 8 (of 8 total)
  • Same error here. Did you get it fixed? Would love to know what you did.

    I’m on a MediaTemple (dv)

    Same thing here…any updates?

    Same problem here as well.

    Me too… Have been going at it for a week and cannot figure this out! Any news from you guys?

    Hi everyone. I am not sure what happened, but shortly after I had this issue it went away. I didn’t do anything to resolve. Had my webmaster log in and check it and he said he was able to easily upload images. Sorry I cannot be of more help.

    One of our clients, had the same issue.

    Finally we found out that the wordpress “HTTP Error” when uploading images, was happening due to a change on the server side. The hosting comany, decided to add APC accelerate to the server in order to increase server’s stability and speed. APC accelerate should work only with FastCGI and not with su, so they set PHP to run as FastCGI.

    When using PHP as FastCGI, if you try to upload a file larger than 128KB, an error “mod_fcgid: HTTP request length 131388 (so far) exceeds MaxRequestLen (131072)” occurs and causes an 550 internal server error. This happens because the value of MaxRequestLen directive is set to 131072 bytes (128KB) by default. One way to correct this (if server uses Plesk), is to edit /etc/httpd/conf.d/fcgid.conf and set MaxRequestLen to a higher value, for example 15MB (MaxRequestLen 15728640). If server uses cPanel, this change can be done via the WHM of the server.

    So, if you can upload images up to 128KB, this is the solution to your problem.

    @ftsakonitis thanks a ton for the tip, man. I didn’t had the “MaxRequestLen” line in the fcgid.conf file on my server, so I added it by myself as “FcgidMaxRequestLen 15728640”.

    ..and it worked, thanks again 🙂

    My VPS is configured with: FcgidMaxRequestLen 211310720 and memory_limit: 128MB, post_max_size: 16MB, upload_max_filesize: 8MB and max_execution_time: 30

    and don’t works, I again get this error for image upload: ‘HTTP error’! 🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘HTTP Error during Picture Uploads in Version 3.3.1’ is closed to new replies.