HTTP Error during API Request, and connect() timed out! in Jetpack - related? (2 posts)

  1. fatgirlphd
    Posted 4 years ago #


    I'm fairly new to WordPress.org so I'm just learning how to use it, so forgive me if I've overlooked something fairly obvious!

    I've just uploaded the wordpress installation to my ftp server and everything seemed to be going well, but I've been getting the following error when I'm trying to import from my .com blog:

    An Unexpected HTTP Error occurred during the API request

    -I've ended up installing the plugin through the FTP server, rather than simply by clicking through on my WordPress dashboard, which has sort of solved it, although it's still failing when I try to import attachments too.

    However, I've now encountered another issue and I'm wondering if it's related, when I try to install Jetpack:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. connect() timed out!

    Could there be something wrong in the backend of the site that's causing these issues? I can't see how it could be anything I've done, purely because I haven't had the chance to mess it up yet! I've already tried to reset the theme to Twenty Ten as suggested on some other forum posts...

    Please help - I'm a newbie but I'm eager to learn!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    This usually means something is incorrectly configured on your web host

    Try contacting your hosts.

Topic Closed

This topic has been closed to new replies.

About this Topic