WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] HTTP Error 503. The Service is unavailable

[Resolved] HTTP Error 503. The Service is unavailable

  • I just upgraded my Windows Server 2008 to Windows Server 2008R2. I was able to upgrade the OS over the top of itself. the blog I host was running just fine prior to the OS upgrade. However, now when I navigate to the blog I get:

    SERVICE UNAVAILABLE
    HTTP Error 503. The service is unavailable.

    Which service is unavailable? How can I troubleshoot this?

    Any help or suggestions is greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The web server isn’t working/available. Unfortunately, it isn’t related to WordPress. It’s a problem at the server configuration level. In a nutshell: https://support.microsoft.com/en-us/kb/2619402

    Additional searching may be required for your specific configuration details.

    the web server is indeed working. All other sites are working. The only one that isn’t is the blog.

    Well, I think we can agree that some service component that is responsible for serving that particular site has suffered a change in configuration that now renders the 503 error. 🙂

    What have you done to troubleshoot?

    Correct. As I mentioned, when I navigate to the blog not, http://blog.jollyrogersmotorcycleclub.com I get the 503 error, but only that site.

    So, so far I’ve confirmed all the components are still there. When I try a phpinfo.php I also get the same 503 error. Don’t know where else to be checking or what service is unavailable.

    Anything in your log files? Your best bet for troubleshooting tips is going to be the available IIS documentation. Log file locations and content will be something you should look into. Some info that might point you in a productive direction (looks like you might be using IIS 7.5)

    troubleshooting 503 errors “IIS 7.5”

    Ok..you are suggesting looking at the IIS logs correct?

    Yes, it’s IIS 7.5

    While I look at the logs etc, what services would be unique to the blog but not to other websites. MySQL is running.

    I don’t have any of those answers. I don’t know to what level or how you have error logging configured. Something that changed (presumably) during the OS upgrade process is now keeping IIS from serving pages on that particular site. I don’t know what that issue may be. Reviewing server and site error logs certainly would be of huge benefit.

    I think I see ~5 domains hosted on that IP address. If all of the root domains are still working properly, perhaps it might be worth taking a look at the sub-domain (blog.jollyrogersmotorcycleclub.com) configuration, if that’s the only one not working any more. Maybe something there has changed. I’m out of guesses, to be honest.

    Yup… all the other domains work just fine. and yup.. only the blog is not, as mentioned. Nothing I see that is obvious.

    Looking for someone that may have an idea as to WHAT server is not available pertaining only to the blog.

    I don’t know what is happening. I checked the AppPool and discovered that both the Blog and WordPress AppPools were stopped. I started both. The WordPress AppPool stays started however, the Blog AppPool keeps stopping automatically.

    I’ve tried the suggestions in the links you provided and none of them make any difference. The JollyBlog AppPool keeps stopping when the App is hit.

    Anyone have any suggestions?

    I fixed the issue. The Blog AppPool kept stopping. Under Advanced Settings for the particular AppPool I changed “Enable 32-Bit Applications” from TRUE to FALSE.

    Issue solved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.