Support » Plugin: IP Geo Block » HTTP Error 500

  • Resolved nesoor

    (@nesoor)


    Hello WordPress members,

    I am using GEO IP on many website’s but out of the blue I get an HTTP error 500 on the frontend on one of my websites. Does anybody know why that is ?

    This is the error log:
    [Mon Dec 31 12:45:44.803108 2018] [lsapi:error] [pid 714454:tid 140241345808128] [client 92.111.239.213:51495] [host http://www.domeinnaamhier.nl] Backend fatal error: PHP Fatal error: Uncaught Error: Unsupported operand types in /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php:968\nStack trace:\n#0 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-includes/class-wp-hook.php(286): IP_Geo_Block->check_capability(Array, Array, ‘wp_user_roles’)\n#1 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array)\n#2 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-includes/option.php(312): apply_filters(‘pre_update_opti…’, Array, Array, ‘wp_user_roles’)\n#3 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-includes/class-wp-roles.php(208): update_option(‘wp_user_roles’, Array)\n#4 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-includes/class-wp-role.php(58): WP_Roles->add_cap(‘swup’, ‘read’, true)\n#5 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-content/themes/swup/functions.php(417): WP_Role->add_cap(‘read’)\n#6 /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-settings.php(443): in in /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php on line 968\n

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @nesoor,

    I’m very sorry about this issue. I urgently released the probably fixed version 3.0.17.2. If you still find the issue, please let me know.

    Thank you for reporting.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @nesoor,

    Backend fatal error: PHP Fatal error: Uncaught Error: Unsupported operand types in /home/nesoor/domains/domeinnaamhier.nl/public_html/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block.php:968\nStack trace:\n#0

    It means something might be blocked. So please keep watching the “Logs” which request would be blocked.

    Sorry for the patience and thanks for cooperation!

    I updated the IP Geo Block plugin yesterday, December 30, 2018 and now I am blocked out of my site. I am getting a 403 error. The error message says: “It appears you don’t have permission to access this page.
    403 Error. Forbidden”.

    Could this be similar to the problem nesoor posted above?

    Thank you.

    Hey Tokkonopapa & 7thAngel,

    I just updatet to the latest version 3.0.17.2 and now I also get “Sorry, your request cannot be accepted.”

    • This reply was modified 10 months, 3 weeks ago by nesoor.
    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear @nesoor and @7thangel,

    I’m very sorry for the frequent update. I overlooked Nesoor’s report. Would you try 3.0.17.3?

    Thanks a lot.

    Hey tokkonopapa,

    I’ll check if it works next year 😉
    Don’t worry its just a few hours, happy new year 🙂

    I would try 3.0.17.3 but I can’t access my WP dashboard or my site.

    You can turn off the plugin via ftp

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @7thangel,

    Sorry about your trouble. Please refer to Quick recovery from blocking on your login page.

    Hi @nesoor, Thank you for your supporting.

    Hey tokkonopapa,

    The update works. Thanks! 🙂

    • This reply was modified 10 months, 3 weeks ago by nesoor.

    I was able to gain access to my site, so I updated to 3.0.17.3. Now it blocks multiple plugins like Wordfence and All-in-One WP Migration. With Geo Block disabled, I have complete access those plugins.
    Sorry tokkonopapa, I deleted the plugin. I loved it when it was working, but I’m always reluctant to update it for fear of what it may break. This is not the first time an update to Geo Block broke things. That said, you have ALWAYS been diligent in finding a solution. I appreciate your efforts and I wish you all the best.

    Hey 7thAngel,

    I also have Wordfence but I do not have any problems with IP GEO Block.
    You can also open a topic, Tokkonopapa has great support so he will probably explain you how to exclude those plugins. IP GEO Block is a great security plugin but sometimes a security plugin such as Wordfence or IP GEO Block can also block other scripts.

    I have many websites running on this plugin and for me it works great 🙂

    Thanks nesoor.

    I agree, Tokkonopapa is relentless in supporting his plugin. I couldn’t ask for better support. I’m going to restore my sites from a recent backup and see if that resolves my issues. I have confidence that will work.

    I’m glad your issues have been resolved. Thanks for the info.

    Thanks Tokkonopapa, your support is awesome!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear @nesoor and @7thangel,

    Thank you so much for taking the time during new year holidays and giving me your feedback, and special thanks for your kind words.

    I’ll keep doing my best to make this plugin statble.

    Thanks again!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘HTTP Error 500’ is closed to new replies.