Support » Fixing WordPress » HTTP Error!

  • Hi there,

    I’ve installed WordPress 2.8.6 succesfully in my server, and got the blog running. But there’s a big issue: I can’t upload images… Everytime a try to do this thru the User CP, it gives me a red “HTTP ERROR”.

    Anyone has a clue on how to solve this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • bump

    You might need to contact your hosting provider and make sure that their services include all the necessary requirements for hosting WordPress. See –


    Add this code in htaccess;

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Also refer this article;

    HTTP Crunching Error


    Shane G.



    cosmictap posted a link that solved the “HTTP error.” problem for me (after all other solutions I tried failed).

    Just for the record, I am using WP 2.9 on HostGator.



    I’m on WP 2.9, and we had a htpasswd authentication on the wp-admin folder.

    The link above from bookchiq worked perfectly.

    (BTW, the browser uploader worked fine. It’s the flash uploader that didn’t work.)



    Just a quick shout out: bookchiq’s link worked for me too… Thanks!

    This might work. All the advice to update my htaccess was not helping. I run my blog on a windows server. This is how I fixed this HTTP error problem.

    With in your Dashboard go to Settings and then Miscellaneous Setting.

    For some reason my hosting site automatically added this to the Store upload files path.


    I deleted it all and replaced it with

    wp-content/uploads (just as recommend.) (Also make sure you have a uploads file in your wp-content folder)

    Now IT WORKS!

    This only took me 8 hours of tweaking to get it to work. Hope this works for you.

    Any help on this will be appreciated; I’ve been battling this for a while.

    Although an .htaccess file appears in my ftp client in a direct search, the file will not download to my desktop, so I cannot modify it. Can anyone tell me the normal location of this file in the directory?

    I tried that and it worked two times, then reverted back to the http error indicator.

    Most recently it works occasionally and not at the other times. Any help?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘HTTP Error!’ is closed to new replies.