Support » Localhost Installs » http error

  • hello,
    i am building a website locally and i recently i keep coming across the same issue.

    i keep getting HTTP ERROR whenever i try to upload photos. i know it have noting to do with the image size as i have been able to upload the exact same photos in the past.

    im not sure if this is a problem with WP or if it has something to do with my PHP in MAMP BUT if anyone can advise on when steps i should follow PLEASE help!

    Thanks

    • This topic was modified 3 weeks, 3 days ago by  Steve Stern. Reason: moved to localhost installs because MAMP
Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello.

    These types of issues can be very frustrating. I’m sorry for the inconvenience.

    Using MAMP is a great tool, and I recently upgraded to the PRO version which I would highly recommend when you can afford it. I also ran into a new program at WordPress Wordcamp called Local by Flywheel (https://local.getflywheel.com – more info here: https://deliciousbrains.com/xampp-mamp-local-dev/)

    My gut reaction is maybe there is something restricting memory, try this:
    Step One: Turn all plugins off
    Does it work? Then turn each plugin on one at a time, otherwise…

    Step Two: Past this code in your wp-config.php file:
    define( 'WP_MEMORY_LIMIT', '256M' );

    My gut reaction is that the PHP settings for post_max_size and upload_max_filesize are too low. (And that the above post is spam, but I digress.)

    However, it’s impossible to know for sure until you provide more information. All HTTP errors have a number between 400 and 530. What is the number of the error you are seeing?

    Also, have you checked the PHP and Apache error logs in MAMP? I’ll bet one of them (probably the PHP error log) will tell you exactly what the problem is.

    ainsworthstudio

    (@ainsworthstudio)

    Hi DionDesigns, just to clarify – my comment wasn’t spam, it was in according to the WordPress/Automattic creed, specifically: “I will communicate as much as possible”

    Why use MAMP at all? OSX comes with Apache web server built in. All you need to do is configure it:
    https://mallinson.ca/osx-web-development/

    I ditched MAMP a long time ago and just drop WordPress in my WWW folder and work.

    Make sure you update PHP to v7 or greater for WprdPress to work.

    https://www.google.com/search?q=update+php+mamp

    I upgraded to php 7.1 yesterday. but before that I couldn’t upload media of any type or size to the Media Library. There is no number following “HTTP error.” Even after changing the file size limits, the same error…

    Suggestions?

    Difficulties in uploading and updating files on localhost can be caused by file permission issues, if the web server does not have file write and directory update permissions on the WordPress files and uploads directory then perplexing problems can occur. One way around these problems is to copy the images and update files from OUTSIDE WordPress using the computer’s native file utilities.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.