Support » Plugin: Compress JPEG & PNG images » HTTP Error

  • Resolved amsgator

    (@amsgator)


    When I try uploading an image (even just one) I get an “HTTP Error” in the dashboard. It seems the image is uploaded and compressed (so are the wordpress generated sizes) so I’ve got no clue what the “HTTP Error” is about.

Viewing 15 replies - 16 through 30 (of 31 total)
  • Plugin Author TinyPNG

    (@tinypng)

    Hi Luke,

    Thanks for the additional feedback.

    Do you get the error immediately after uploading, or after some amount of time?

    A HTTP error could also be caused by the compression of all the image sizes for a specific image taking too long. Do you happen to have a lot of different image sizes configured to be compressed? And are the images that you get the HTTP errors for large in file size? The combination of large images with many image sizes might contribute to these errors.

    Your last comment about the loading icon that never finishes after uploading a file is indeed a bug that we can reproduce. It should however not be related to the HTTP errors that you’re getting. It’s merely a problem of updating the client when the compression finishes. A refresh of the media library should show the correct state of the image.

    Switch to the following plugin. I’m never looking back, : )

    https://wordpress.org/plugins/wp-image-compression/

    Hi there,

    We receive the error after a few seconds when the upload progress bar has reached 100% upload status.

    We have around 14 image thumbnails generated for each image, is this an issue?
    The image file sizes are all easily smaller than 1mb each, it doesn’t appear to be a file size issue (as the uploads work fine after disabling the plugin).

    Thanks!

    Plugin Author TinyPNG

    (@tinypng)

    Hi Luke,

    Thanks for the update.

    If you get an error when the image has been uploaded to WordPress then the errors you’re getting don’t seem to be related to the number of image sizes you have configured. We have seen in the past that some users were getting errors when they had a lot of image sizes configured because the compression of all image sizes took too long. That doesn’t seem to be the case for you.

    Are you getting this for each image you upload to WordPress? What do you see in your Media Library after uploading an image you received an error for, does it show an error there as well?
    Also, do you use the latest version of the plugin? Do you happen to have any other plugins installed that are processing images?

    Finally, you could also enable the debug mode in WordPress https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG and send us the logfile after having reproduced the same HTTP error so that we can have a look to see if it contains useful information to debug this problem.

    Hi there,

    Yes that’s correct – we don’t have any image upload issues, it’s just the compression loading indicator that sometimes does not mark an image as ‘completed compressing’.

    We do get this HTTP error for each image upload:
    1. Media Library: https://dl.dropboxusercontent.com/u/12249901/Temp/media-library-error.jpg

    2. Uploading in the custom post: https://dl.dropboxusercontent.com/u/12249901/Temp/post-edit-media-upload.jpg

    Strangely enough the images still do upload though. And they start compressing afterwards. But this makes it really difficult to add images when we would then need to save the custom post page to then re-add the images in to the custom post.

    Is there possibly a fallback option you could add to the plugin to enable/disable automatic compress on image upload? That way we could compress the newly uploaded images at a later date using the bulk compressor.

    I ran the debugging on our test server (with the same setup) and the .log file did not record anything from the HTTP Error.

    Thanks for your support so far!

    Plugin Author TinyPNG

    (@tinypng)

    Hi Luke,

    Thanks for your patience! Unfortunately “HTTP error” is a pretty broad error so it is difficult for us to know exactly what is going wrong. We’ve had some users report that this error occurs when the max_execution_time in the .htcaccess file is set too low. Can you please check what your max_execution_time has been set to in your .htaccess file? By default the max_execution_time should be set at 30 seconds which is quite low. We suggest setting that value to 300.

    To change your max_execution_time please follow the instructions here: http://docs.presscustomizr.com/article/171-fixing-maximum-upload-and-php-memory-limit-issues

    Currently there is no way to enable/disable the automatic compressions of an image unless you disable the plugin entirely.

    Let us know if that fixes your issue!

    Thanks for your response.

    Our server’s php max execution time is already set to 300.
    Moving forward I may just rely on a server-side lossless image compressor seeing as it doesn’t have any issues running that way.

    Thanks for your help!

    StanfordAlan

    (@stanfordgriffith)

    I have this issue too, and it just started yesterday on a site I’ve been building for several days. Both have the current versions of WP and TinyPNG. One has a free API while the other has a paid one.

    It also happened on a brand new site. It’s definitely something with TinyPNG, but it is intermittent. I have noticed, however, it’s far more likely to happen with a larger image than a smaller one. That said, I just uploaded a 52KB JPEG that failed with an HTTP error and then worked perfectly the second time.

    If you’d prefer I start a different thread since this one is a few months old, please let me know.

    Thanks!

    Plugin Author TinyPNG

    (@tinypng)

    Hi,

    Thank you for contacting us! Are your websites perhaps hosted by WPEngine? There have been some reports of users on that host experiencing these issues; we suspect there is something on their end that kills the upload request when it takes too long.

    Could you send us an email at support@tinypng.org with your PHPinfo and if possible a screenshot of your browser when the HTTP error occurs (with the browser console visible), then we can help you further.

    Hi,
    The same error message here “HTTP error” with the same .
    Hosted by SiteGround.

    Would you please provide possible solutions/alternatives? Thank you 🙂

    Plugin Author TinyPNG

    (@tinypng)

    Hi Milesnext,

    Thank you for contacting us! Have you already tried increasing the max_execution_time?
    To change your max_execution_time to 300 please follow the instructions here: http://docs.presscustomizr.com/article/171-fixing-maximum-upload-and-php-memory-limit-issues

    If that does not solve the issue could you send us an email at support@tinypng.org containing all the information you have.
    Include the PHPinfo.

    You can also enable the debug mode in WordPress: https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG
    Try to reproduce the HTTP error and send us the logfile.

    Hi,
    Thank you for prompt response.

    It might be cause of that but unfortunately my share hosting environment do not allow me to alter the setting.
    But interestingly after the message “HTTP error” I refresh the page and check the image size from ftp, the image was uploaded and properly resized.

    Any suggestion? I assume it functions properly and I would not really mind the message if images are uploaded and resized properly.

    Thank you 🙂

    Plugin Author TinyPNG

    (@tinypng)

    Hi,

    Thank you for your reply!

    Could you send us an email at support@tinypng.org containing all the information you have. Including the PHPinfo and screenshots of the error. Thanks!

    amsgator

    (@amsgator)

    @milesnext I’m willing to bet you’re missing some of the other image sizes generated by wordpress, or they’re not all compressed.

    amsgator

    (@amsgator)

    I was able to set the max_execution_time to 300 with user.ini

    I’ll see how it works.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘HTTP Error’ is closed to new replies.