Support » Plugin: Ultimate FAQ - WordPress Q&A Plugin » HTTP-Code 404

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi Conrad-GZ,

    We just checked your site and it seems to be showing the categories fine, we checked the following links and it populated the right FAQs and doesn’t show any 404 error. Please update if you’re still facing the error so that we can look into what’s causing the error?

    https://bayernlogo.de/ufaq-category/allgemeines/
    https://bayernlogo.de/ufaq-category/flyer-design/
    https://bayernlogo.de/ufaq-category/logo-design/

    Hi,

    thanks for reply and your check-up.

    Pls, have a look e.g. at this page (post?): https://bayernlogo.de/ufaqs/wie-besprechen-wir-die-dinge-die-uns-wichtig-sind-bei-der-entwicklung/

    There is (like on posts) a link after Head “am 20 Mai 2018”: “20. Mai 2018

      This links to 404!

    Furthermore:
    There beside is (like on posts) a link to “author” “conrad” which is disabled in the settings.

    Now I hope that you can realize the issues. What´s to do?

    Thanks a lot for support and quick reply!
    Conrad

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi Conrad,

    For the FAQ single post pages, it would be your theme that controls the look and layout.

    Because the FAQs are just a custom post type, the single post page for FAQ posts would, by default, make use of your theme’s single.php template file.

    There’s two options here:

    1) Go through the “Customize” options for your theme (i.e. click the “Customize” link at the top of the page when you’re logged in and try to find a setting that controls the “Post metas”. From there, see if it’ll allow you to hide the author/date.

    2) If no options exist for suggestion #1, you’ll need to modify the single post page for FAQs. We suggest duplicating your single.php file and creating one specifically for our post type, as discussed here: https://codex.wordpress.org/Post_Type_Templates. Our post type is called “ufaq”, so you’d want to call your template file “single-ufaq.php”.

    Hi,

    thanks for your quick reply.

    Unfortunately you are still not solving the substantial problem with the 404-Link! So I have to assume that there is no solution. Right?

    Regards
    Conrad

    • This reply was modified 2 years, 4 months ago by Conrad-GZ. Reason: correction
    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    For the 404 error, it sounds like it might just be that you need to flush your permalinks, something that is often necessary when new custom post types are registered in WordPress or changes are made to custom post types. To do this:

    – In the main menu, go to “Settings > Permalinks”.
    – Scroll down, if needed, and click “Save Changes”. No need to actually make any changes.
    – Rewrite rules and permalinks have now been flushed.

    New problem:
    The category-links are linking not to the category-page but rather again to the origin page itself.

    Whats to do?

    Thanks for reply.
    Conrad

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi Conrad,

    You might have to clear your browser cache and then try that again. We re-checked and it is showing the categories fine, we checked the links again and it populated the right categories and FAQs, and doesn’t show any 404 error.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘HTTP-Code 404’ is closed to new replies.