[resolved] http 500 internal server error after coping files from server to localhost (8 posts)

  1. pmathobela
    Posted 3 years ago #

    Hi All,

    I have tried resolving the issue in the last 6hrs without success.

    Its my first time coping a wordpress site to local machine. I've copied using filezilla to local machine, where i am using xampp. MySql and Apache services are running fine. Before importing the database i tried checking http://localhost/folder_name, and i get server error instead of database error as per the instruction.

    I've searched all over the net for help and could not get it resolved. Pls assist!


  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try reviewing one of the xamp resources on installing WordPress locally

  3. pmathobela
    Posted 3 years ago #

    Hi Esmi,

    I had one installed locally before and it's still working fine.

    I created another folder in htdocs, copied this one(all files) from live server to local, but its not working.

    I will do as you suggest and will let you know.

  4. pmathobela
    Posted 3 years ago #


    Im still struggling to get it right. Ive even went to a point of comparing file to file, but nothing seems wrong to me. All the files have been copied to localhost and still getting the error.

    Any other suggestions???

  5. Jose Castaneda
    Posted 3 years ago #

    What version of XAMPP are you running? One possible solution (but extreme) would be to re-install XAMPP.

    What's your PHP configuration like? Is it the default?

  6. pmathobela
    Posted 3 years ago #

    Hi Jose,

    I replaced the old xampp with newer version(1.8.1) which includes:
    •Apache 2.4.3
    •MySQL 5.5.27
    •PHP 5.4.7
    •FileZilla FTP Server 0.9.41
    •Tomcat 7.0.30 (with mod_proxy_ajp as connector)
    •Strawberry Perl Portable
    •XAMPP Control Panel 3.1.0 (from hackattack142)

    I then copied files to local(htdocs). I am still getting the "Http 500 internal server" error. I am on W7 OS

  7. pmathobela
    Posted 2 years ago #

    Finally found it, it was on internet options - tools -> advanced -> then deselect (show friendly HTTP error messages)

  8. criscom
    Posted 2 years ago #

    check your .htaccess. it might not be writeable. make it writeable.

Topic Closed

This topic has been closed to new replies.

About this Topic