Support » Plugin: Conditional Fields for Contact Form 7 » http 500 error after plugin is activated in multisite

  • Resolved derbademeister

    (@derbademeister)


    After I installed the Contact Form 7 Conditional Fields Plugin in my WordPress installation (4.9.8) the associated site of my network fails to load with a http 500 error.

    The WordPress debug.log tells me: PHP Fatal error: Class ‘Orbit_Fox_Module_Abstract’ not found in /var/www/…wordpress-path/init.php on line 15

    But the Orbit Fox Plugin is also installed and activated. Am I missing something?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jules Colle

    (@jules-colle)

    Could you try and disable the Orbit Fox Module?

    Yeah. That was the first thing as well as a reinstall.
    Both didn’t work.

    Plugin Author Jules Colle

    (@jules-colle)

    Well, if you disable the plugin, you should not get this error anymore:

    The WordPress debug.log tells me: PHP Fatal error: Class ‘Orbit_Fox_Module_Abstract’ not found in /var/www/…wordpress-path/init.php on line 15

    So, which error do you get instead?

    [14-Jan-2019 20:37:08 UTC] PHP Fatal error: Class ‘Orbit_Fox_Module_Abstract’ not found in /var/www/wordpress/init.php on line 15

    It’s the same although the plugin is removed/uninstalled in the entire multisite network.

    Plugin Author Jules Colle

    (@jules-colle)

    What is the exact path to the init.php file? There should be no such file in the WP root as far as I know.

    Could you paste a snippet around line 15 of the file?

    • This reply was modified 3 months, 1 week ago by  Jules Colle.

    The file is directly inside the wordpress root folder.

    Here is the snippet:

        10	define( 'BEAVER_WIDGETS_URL', plugins_url( '/', __FILE__ ) );
        11	
        12	/**
        13	 * Class Beaver_Widgets_OBFX_Module
        14	 */
        15	class Beaver_Widgets_OBFX_Module extends Orbit_Fox_Module_Abstract {
        16	
        17		/**
        18		 * Beaver_Widgets_OBFX_Module constructor.
        19		 *
        20		 * @since   2.2.5
        21		 * @access  public
        22		 */
    

    I just renamed the init.php to disable it and activated the plugin. Everything works. Don’t know why and if it is causing trouble with something else now which needs the init.php.
    I will observe this. Thanks for your help.

    Plugin Author Jules Colle

    (@jules-colle)

    there should be no init.php file in standard wordpress installations. It might be injected by a plugin that is no longer used. You should be fine without the file.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.