Support » Plugin: WooCommerce » http 500 error

  • Resolved aowisdom50

    (@aowisdom50)



    Hello,

    After updating to 3.3.4, http 500 not connected error came up.
    I could not appoach both to admin area and front-end.

    My website got active after deactivating plugin folder.

    Thanks,
    JiYeon

Viewing 13 replies - 1 through 13 (of 13 total)
  • beavis82

    (@beavis82)

    We had a similar issue with one of our sites. A 500 server error appeared on both the front-end and WordPress admin area following the update to Woocommerce 3.3.4, and server logs included multiple ‘end of script output before headers’ errors.

    In our case the issue was fixed by switching to PHP version 5.6 (our web host was running PHP 5.3 for some reason) so check to see if your PHP version is causing the problem? 5.6 is Woocommerce’s recommended minimum version.

    • This reply was modified 11 months ago by  beavis82.
    Plugin Support Con Schneider

    (@conschneider)

    Automattic Happiness Engineer

    Hi there,

    A 500 server error masks the underlying condition and provides no debugging information. Normally any error does output additional details that provide information on the origin and type of error, this is called debug information. Debug information is necessary for developers to understand what occurred when. Based on this one can make deductions and try to formulate a diagnosis. This diagnosis can then be tested to see if it checks out.

    500 errors are often setup so that an outside party does not get any information they can use to calibrate their attack vector. Most hosting providers log the information internally in this case.

    Taking a look at the PHP error and server log files from your provider should give you helpful pointers.
    WooCommerce also attempts to log any fatal errors. You can find these under WooCommerce > Status >> Logs (click on the tab). After clicking on the logs tab examine the dropdown on the right for any “fatal-errors” entry.

    Kind regards,

    sarahweb

    (@sarahweb)

    just testing the PHP version in case that is why I got the same error myself, no logs visible and no error_logs either even though debug is switched on – just seemed to redirect in a loop until timed out – but thank you I will check on the PHP version now and report back

    aowisdom50

    (@aowisdom50)

    I am using PHP 7.1.15 and went back to wc 3.3.3.
    I will check any plugin conflicts and wait for more update for my theme flatsome.

    • This reply was modified 11 months ago by  aowisdom50.
    Plugin Support Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Definitely want to help get to the bottom of this, but need more details about the error that happened. Could you ask your web hosts to look at the php error logs to see what fatal errors were happening around that time?

    Alternatively, you can enable WP_DEBUG and WP_DEBUG logging and you’ll see the errors in the log file: https://codex.wordpress.org/WP_DEBUG

    sarahweb

    (@sarahweb)

    I’m not able to change PHP version currently – but I will see if I can test on another server of mine to see if I can replicate it – won’t be ideal as a different server but might just help me work out if PHP version issue or not

    Plugin Support Mikey Arce

    (@mikeyarce)

    Automattic Happiness Engineer

    Thanks @sarahweb,

    Let us know what you find!

    @mikeyarce ok so the exact same WordPress files and DB worked on a 5.6 version – I was then able to upgrade the Woo to 3.3.4 and that worked with no redirect issues or errors

    however as its a different server and server set up I am not 100% sure that the PHP version was just the culprit..

    Plugin Support Mikey Arce

    (@mikeyarce)

    Automattic Happiness Engineer

    Hi @sarahweb,

    So with this new setup you are still getting a 500 error when trying to log in? Or what is the problem you are seeing?

    If you disable all plugins and switch to a default theme, does it still happen? If you enable just WooCommerce does it happen?

    @mikeyarce exact opposite all working perfectly!

    not sure if that helps at all though but I copied all files across and DB and everything worked great

    Plugin Support Mikey Arce

    (@mikeyarce)

    Automattic Happiness Engineer

    @sarahweb,

    So what can sometimes happen is that when you disable WooCommerce, something that was depending on WooCommerce being active (like an extension for WooCommerce) will stop running so the problem will go away. So the problem might not be from WooCommerce but from something depending on WooCommerce.

    If you disable all plugins except for WooCommerce, do you still get the same issue? If you copied the whole site to another server and it worked, it might be that something on the current server is not working properly – maybe check the error logs?

    it was certainly woo that was the issue but no error logs at all shown – it was not even registering that was the odd thing! I will keep trying to determine what it was but certainly a server setting difference could easily be part of it

    I do not know what was the culprit but now update is succcessful.
    What I did is ;

    1. Upgraded from PHP 7.1 to 7.2
    2. Raised pm.max_children = 5 to 40 –> I got notice to raise it.
    3. I sometimes got notice memory exhaused and raised memory_limit.

    I am happy now !!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘http 500 error’ is closed to new replies.