WordPress.org

Forums

Http 403 forbidden (8 posts)

  1. Rocky074
    Member
    Posted 1 year ago #

    Hi,
    Everything was going well with working on a wordpress theme using Wamp. Now, after an unsuccessful attempt to upload multisite I have reloaded wamp and now get http 403 forbidden.
    Any advice that you can give in simple terms would be appreciated.
    Thanks

  2. Rocky074
    Member
    Posted 1 year ago #

    Ok, so I have had a look around and still can't find a solution but whatever I have done (one of the things I have done is remove the allow multisite line in wp-config) I now get 404 not found error.
    I am guessing that this is a local host issue as I can't open any local host pages.
    I have checked my hosts settings and they are:

    # Copyright (c) 1993-2009 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost

    127.0.0.1 localhost

    Any assistance would be most welcome, in the meantime I will continue to spend time looking into this even though I am wandering aimlessly through forums etc.

  3. Hans Nagtegaal
    Member
    Posted 1 year ago #

    Is there anything in your Apache logfiles? Did you change the permissions on the file system?

  4. Rocky074
    Member
    Posted 1 year ago #

    Hi Hans,
    This is the last few errors from the Apache logfiles:
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host.example.com] does not exist
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host2.example.com] does not exist
    [Thu Mar 06 11:12:07 2014] [notice] Apache/2.2.22 (Win32) PHP/5.3.13 configured -- resuming normal operations
    [Thu Mar 06 11:12:07 2014] [notice] Server built: May 13 2012 13:32:42
    [Thu Mar 06 11:12:07 2014] [notice] Parent: Created child process 8008
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host.example.com] does not exist
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host2.example.com] does not exist
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host.example.com] does not exist
    Warning: DocumentRoot [C:/Apache2/docs/dummy-host2.example.com] does not exist
    [Thu Mar 06 11:12:08 2014] [notice] Child 8008: Child process is running
    [Thu Mar 06 11:12:08 2014] [notice] Child 8008: Acquired the start mutex.
    [Thu Mar 06 11:12:08 2014] [notice] Child 8008: Starting 64 worker threads.
    [Thu Mar 06 11:12:08 2014] [notice] Child 8008: Starting thread to listen on port 80.
    [Thu Mar 06 11:12:08 2014] [notice] Child 8008: Starting thread to listen on port 80.

    Thanks for your time.

  5. Rocky074
    Member
    Posted 1 year ago #

    I should say that I am uncertain if I changed the permissions, how would I have done this and revert them back?

  6. Hans Nagtegaal
    Member
    Posted 1 year ago #

    Setting the permissions is described here: http://support.microsoft.com/kb/308419

    The apache log doesn't tell me much. The warning is because there is still the example hostname as defined in httpd-vhosts.conf. Nothing that can cause your 403.

    another thing that comes to mind, if you set-up WordPress as multi-site you must make sure the weblogs have the correct URL in the wp_blogs table. Are you sure they are correct?

  7. Rocky074
    Member
    Posted 1 year ago #

    I have checked that users have full permissions. Also, I have removed the allow multisite coding from the wp-config php file.
    Still getting 404 not found.

  8. Rocky074
    Member
    Posted 1 year ago #

    I have had a further look into stuff and checked MySQL error log and found this sort of error and wonder if this is really the source of my problems? If so I don't know how to fix it.

    140305 15:23:14 [ERROR] Cannot find or open table gallery/wp_site from
    the internal data dictionary of InnoDB though the .frm file for the
    table exists. Maybe you have deleted and recreated InnoDB data
    files but have forgotten to delete the corresponding .frm files
    of InnoDB tables, or you have moved .frm files to another database?
    or, the table contains indexes that this version of the engine
    doesn't support.

Topic Closed

This topic has been closed to new replies.

About this Topic