Support » Plugin: Cloudflare » HTTP/2 Server Push not working with Autoptimize

  • Noticing this feature is trying to prefetch the original css files…not the autoptimize css minified combined files…why…?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hey guys, the Autoptimize author wants to help you get your plugin fixed, please review:

    https://wordpress.org/support/topic/autoptimize-not-compatible-with-cloudflare-https2-prefetch/

    He is very helpful and responsive, thanks!

    He is very helpful and responsive

    well thank you @jiggaman

    the Autoptimize author wants to help you get your plugin fixed

    it would indeed be great for CloudFlare to HTTP/2 prefetch the autoptimized CSS/ JS files (and not the non-optimized JS/ CSS files from the wordpress style- and script-queues). Using AO’s autoptimize_filter_cache_getname filter this might even be pretty simple 🙂

    if need be you can contact me also at futtta-at-gmail-dot-com.

    have a nice evening,
    frank

    Plugin Support 404ndy

    (@404ndy)

    Hi @optimizingmatters

    Thanks for offering to help! I’ll see if I can put you in touch with the folks here actively working on our plugin.

    -Andy

    Great love the team work!

    This should be a pretty quick fix…ideas on a release and/or can you post what changes need to be made to cloudflare to enable the bug fix prior to the release? (lines of code and where)

    Want to get these sites moving faster! And also not load unnecessary files.

    Thanks!

    Any update on this?

    I’d like to bump this as well, having the same issue with Cloudflare preloading the original css instead of autoptimize, it adds lots of unecessary http requests too.

    Thanks!

    Hi guys,

    Any update? Having the same problem here.

    • This reply was modified 1 year, 8 months ago by cmgeoogz.

    also trying to disable the server push by setting it to false and nothing happens. webpagetest still read the server push files.

    How do I disable it?

    Thanks!

    or should I disable AO plugin and let the HTTP/2 runs?

    The HTTP2 technology removes the need for combining css and js since they now load at the same time instead of one at a time, so limiting the number of request is not as critical as it once was.

    The server push takes this technology further by preloading the css or js earlier so you have to choose which elements should load or is needed for the important page element to render.

    The cloudflare implementation of the server push is on the very early stage and will simply preload all or most of the css and js which is not really recommended. It would be best to manually select which item will be server pushed.

    There are no absolutes in web performance, only assumptions validated by comparing test-results and choices based on test conclusions 😉

    Re. push; on lower-bandwidth connections pushing (many) resources can actually slow a page/ site down.

    Re. push; on lower-bandwidth connections pushing (many) resources can actually slow a page/ site down.

    maybe this is what is happening to my pages right now ( https://bit.ly/2EkDPA1 -webpageresults ). Anybody know how can I disable server push in shared hosting?

    I did this ( How do I enable HTTP/2 Server Push in WordPress – https://bit.ly/2V6bnaz ) to activate the server push but when no luck on disabling it.

    I even activated the CF Plugin and delete the code on wp-config.php but still no good.

    or anyone can give me some insights on what is going on in my pages/ I re-run the page and get A Grade in First Byte Time ( https://bit.ly/2T4qTGC )

    • This reply was modified 1 year, 8 months ago by cmgeoogz.

    well, based on that last webpagetest-link you’re not HTTP/2-pushing any more? 🙂

    it is @optimizingmatters

    there’s a server push above “Request Headers Section” and I think I’m going to be crazy on how I will disable this :'(

    #calling911

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘HTTP/2 Server Push not working with Autoptimize’ is closed to new replies.