Support » Fixing WordPress » HTML/Visual missing on 3.4.1 and 3.4.2

  • Resolved aliput


    Can anyone help with this issue please? Both the HTML and Visual buttons in posts and pages is missing. These are the facts:

    1. There is NO evidence of them in the page code (more about this further down)

    2. This is happening on 3 laptops! (all different makes 1 mac(os10.8.1) 2 pcs – one new hi-end pc(latest vers. Windows) /one fairly old)
    3. My two desktops (mac and pc) show 6 instances of the word Visual in the source code but my laptops show only 4.
    4. the two lines that are missing in the source code (ver.3.4.2) are:
    <a id="content-tmce" class="hide-if-no-js wp-switch-editor switch-tmce" onclick="switchEditors.switchto(this);">Visual</a>
    <a id="excerpt-tmce" class="hide-if-no-js wp-switch-editor switch-tmce" onclick="switchEditors.switchto(this);">Visual</a>
    (The same applies for the HTML button)

    5. I have gone through every suggestion including emptying cache files – both browser and .js (even emptied computer cache to see if it was that) / the concatenation bug fix / upgrading to the latest version of WP (this started with 3.3.2 – 3.3.1 was fine!) / manual installs / changing permissions / upgraded all browsers / even tried adding the google plugin in desperation / disabling all plugins / deleting all plugins / tested with theme 2011 / have tried adding the extra tinyMCE files and folders the list goes on…
    6. I have tested this on many devices since it appeared – even smart phones and it works! This only seems to be happening on laptops.
    7. I have created new websites with a fresh install of 3.4.1 and now 3.4.2 – still the same issue.
    8. I have used different servers with different service providers.
    9. Browser types don’t make a difference – have tried them all:
    Opera(mac/pc) firefox(mac/pc) Safari (mac/pc) Internet Explorer vers. 6 โ€“ 9
    10. Have even paid to upgrade my mac laptop to the latest system software.

    Each one of these processes I’ve tried starting from scratch each time to eliminate any possibility of cross pollution. It’s taken me weeks to get to this point!

    PLEASE HELP! I was hoping the upgrade to 3.4.2 might solve the issue – no luck!

    What I can’t understand is why the buttons code is not being written into the html! Even in a default theme on a fresh install, yet it appears (and works) when viewed on a desktop computer!!?

    Any help would be appreciated – thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Have you tried different networks like take a laptop to Starbuckies?

    IT IS SOLVED!!!! This is what the problem was.
    My anti-virus had an anonymiser running which was hiding details of my operating system and web browser detail. Specially it was obfuscating my web browsers user agent strings: which looked like this: Mozilla/5.0 (000000000; 00000 000 00 0 0000; 0000000) DDDDDDDDDDDDDD DDDDDDDDDDDDDD

    WordPress was not able to determine whether any of my browsers were up to date and therefore had hidden the buttons from the admin screen. Upon disabling this annoymiser, full functionality has been restored in my wordpress admin.

    My virus software is VirusBarrier, but presumably this may apply to any software that has a “Hide information about my computer and web browser” checkbox.

    I hope this helps somebody else.

    can u please define it in simple steps what to do with it? i am struggling for the same … i m using AVG antivirus …

    i have tried it by deactivate antivirus and installed word press again but the problem is still there… no visual/html toolbar :S

    m not too good in technical terms ๐Ÿ™

    Hi Clara_readinga.

    We’ll do this a step at a time.

    First question, what computer are you running, mac or pc?

    The first thing to check is your user-agent.

    Go to the following website Upon entry the first blue box you see will show you what your user agent is, mine used to say exactly this:

    Your User Agent: Mozilla/5.0 (000000000; 00000 000 00 0 000000) DDDDDDDDDDDDDDDDDD DDDDDDD DDDD DDDDDD DDDDDDDDDDD DDDDDDDDDDDDD

    Copy and paste your user agent in a reply to this post if it looks similar to my old one above.

    If, however, it looks something like this:

    Mozilla/5.0 (iPad/Mac/Windows NT 6.1 whatever; U; CPU OS 3_2 like Mac OS X; en-us) AppleWebKit/531.21.10 (KHTML, like Gecko) Version/4.0.4 Mobile/7B334b Safari/531.21.102011-10-16 20:23:50

    Then don’t show it on the reply but please let me know it looks similar.



    aliput, my user agent is the same as your old one above.
    Please advise on what to do next.

    wow Thanks to Aliput. I had information hiding on my firewall and the same thing was happening.

    Turned of the Firewall feature and it is working

    Big Thanks!

    Great news rlawrentz! ๐Ÿ™‚ Glad you’re sorted.

    @kirayamato1992. Sorry! I missed your last post. Your anti virus software will have settings or preferences. Within those settings there will be a tab which has

    Hide information about my computer and web browser


    Hide information about the last web site visited

    In VirusBarrier this is found under the ‘Surf’ tab.
    If you have AVG or another you will have to hunt for the options. They may be slightly worded differently. If you find them can you post them on this thread please?

    Best of luck!

    Have you tried :

    switching on/off the “disable visual editor” option from user profile.

    Hi Gabriel. Thanks for the suggestion. Yes, it was the first thing I tried.
    We’ve discovered that it is to do with some anti virus software on certain machines.

    rlawrentz if you are still following this thread, can you provide steps that might help other folk on here? I notice your settings were applied in your firewall.

    Hey, I’m having the same problem of no toolbar in the visual or HTML editor, but I have absolutely NO antivirus software running. And I’m a newbie, I haven’t installed any weird codes or anything. I’ve only had this blog maybe a week or so. Sometimes the toolbar was there, but last night it disappeared! Doesn’t matter if I’m starting a new page or a new post or what. And yes, I tried checking the “disable visual editor” and it’s not checked.

    As per the Forum Welcome, please post your own topic. Your problem – despite any similarity in symptoms – is likely to be completely different.

    @teresajean. Hi this IS a different issue. Your issue is solved by doing the following:

    open your wp-config file

    copy the following piece of code:
    define('CONCATENATE_SCRIPTS', false );

    place the copied piece of code just before the [[ require_once(ABSPATH . 'wp-settings.php'); ]] line:

    This should solve your problem.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘HTML/Visual missing on 3.4.1 and 3.4.2’ is closed to new replies.