• Resolved sjnbham

    (@sjnbham)


    When an HTML formatted email is sent, it isn’t including the merge tag content and the HTML tags are visible in the body of the email. We tried viewing the email in Outlook Web Access and Outlook Android mobile client. The body of the email ends up looking like this:
    *****************************************************
    :
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8

    <p>Title: </p>
    <p>Author: </p>
    <p>Link: </p>
    <p>Please review this news release, provide feedback, or Publish it.</p>
    *****************************************************

    I tried toggling off and on various settings, but it didn’t seem to affect a change on the merge tag content showing up or the HTML being displayed as expected in the body of the email. We’re using Notifications Version 7.0.3.

    Thanks for any help you can send our way.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter sjnbham

    (@sjnbham)

    Looks like the merger tag content is being populated now. So it’s just the HTML tags in the body of the email that appears to be an issue. Here’s what the email body looks like now:

    *****************************************
    :
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8

    <p>https://mysite.wpengine.com</p&gt;
    <p>Available Updates</p>
    <h3>Plugin updates</h3>

    • Gutenberg <i>(current version: 7.8.1)</i>: 7.9.0

    <p> </p>

    Thread Starter sjnbham

    (@sjnbham)

    Found Notifications > Settings > Carriers > Email > Unfiltered HTML > “Allow unfiltered HTML in email body” and turned it on. The body of the emails appears to be formatted correctly now. Not sure if this was on or off by default. If it’s off by default, it would be good to have it on out-of-the-box.

    Thanks!

    Plugin Author Kuba Mikita

    (@kubitomakita)

    It was off by default, but this prevents the visual editor to work correctly and now everyone wants to write HTML by hand 🙂

    I’m glad you resolved!

    Thread Starter sjnbham

    (@sjnbham)

    Maybe I missed something in the settings? I didn’t see an option to use a visual editor and have the resulting email format be HTML to retain formatting when sent. I tried toggling between HTML and Plain if that made any difference and it didn’t appear to show a visual editor option when creating a notification.

    Plugin Author Kuba Mikita

    (@kubitomakita)

    With email set to HTML and disabled the Allow unfiltered HTML in email body option, the visual editor will be available. That would be the old WP Editor – TinyMCE.

    Thread Starter sjnbham

    (@sjnbham)

    OK – I’m seeing it now. I was confused by the options because early in my testing, I think I turned the Allow unfiltered on because I wasn’t initially seeing the merge tag content and thought maybe the unfiltered option might be affecting that.

    Thanks for that assist!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘HTML markup in body of email’ is closed to new replies.