• Resolved bruno05

    (@bruno05)


    I have 2 html fields – header and footer. If i place them on the pdf they work fine but do not show on the notification email. If i place the html within the form, then gravity forms show both html fields on the top before the product and other fields. the pdf still displays the header and footer (it has) correctly but now I have 2 headers and 2 footers as the pdf picks up the 2 html fields from within the form. How do I resolve this? I tried having th e html within the form ( removing it from the pdf) and they display correctly on the form, but the notification email and the pdf then show both html fields before the other fields. Cannot get the footer to show after the fields.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jake Jackson

    (@blue-liquid-designs)

    Thread Starter bruno05

    (@bruno05)

    I do not want to hide the fields as one is the header and the other footer. I want ti displayed as such:

    Header html

    form fields

    footer html

    both in pdf and notification email. only way to do that is putting them in the form. but the end result is as such

    header html

    footer html

    form fields.

    i do not know what logic the allfields erge tag uses. you would think the same way the fields are layed out in the form. but it does not do that for the html fields.

    Plugin Author Jake Jackson

    (@blue-liquid-designs)

    To clarify, you mentioned in the original message that the native PDF Header and Footer settings are working fine. If you feel the need to add HTML fields to your form for other reasons, which you don’t want to include in the PDF (because the content is already included in the PDFs native Header and Footer), you can hide those fields

    You should reach out to Gravity Forms support for help with your Notifications. We only support Gravity PDF. That said, you can always add HTML directly to the Notification Message setting.

    Thread Starter bruno05

    (@bruno05)

    I think I have figured out – sort of. the issue is the html field and how gravity forms and your pdf reads the same. with 4 html fields, it stacks the html first and then the form fields. On the notification email I manually made the order as such:

    Header html

    Notes html field

    form fields

    thank you html field

    footer html

    This is how it is set up in the form as well. Not using the allfields merge tag in the email. So email notification is correct now. In the pdf, I put the header and the notes html in the header field and put the thank you html and the footer html in the footer field. still did not fix it as the pdf picked up the html fields from the form and stacked them first. now i have several html fields. I will remove all html filds from the form as it seems like that is a bug with the allfields merge tag and the way they get stacked first. is your pdf also using the allfields tag and hence why the html fields are stacked together first?

    Thread Starter bruno05

    (@bruno05)

    got it to work by removing the html fields from the form and manually inserting them in the header/footer of the pdf. It is a bug the way the html fields are read and all stacked first before any other form field.

    Plugin Author Jake Jackson

    (@blue-liquid-designs)

    Glad you were able to find a solution 👍

    It sounds like you may have a plugin or theme conflict with Gravity Forms, as out of the box the {all_fields} merge tag won’t output HTML fields. Best to contact Gravity Forms to help you diagnose the specific cause.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘html field placement’ is closed to new replies.