WordPress.org

Forums

html error (5 posts)

  1. connie1
    Member
    Posted 6 years ago #

    When I ran a validation test for my site http://www.marylandtriallawyer.net I got 1 error as follows: How do I fix this? Thank you in advance.

    Validation Output: 1 Error

    1. Error Line 231, Column 55: document type does not allow element "li" here; missing one of "ul", "ol", "menu", "dir" start-tag

    …75742611" class="widget widget_text"> <div class="textwidget">Copyright

    The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

    One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").

    Here is the line in error:

    #231 <li id="text-375742611" class="widget widget_text"> <div class="textwidget">Copyright 2009 Constance A. Camus</div></a>

  2. lhoylhoy
    Member
    Posted 6 years ago #

    just paste here your code ok?

  3. Chris_K
    Member
    Posted 6 years ago #

    @lhoylhoy - easier if you just follow her link and validate it ;-)

  4. lhoylhoy
    Member
    Posted 6 years ago #

    hehe sorry i didn't notice hehe!

  5. Darran
    Member
    Posted 6 years ago #

    You were missing a <ol> or <ul>, just nest your <li> within them and it will validate.

Topic Closed

This topic has been closed to new replies.

About this Topic