WordPress.org

Forums

FBF Facebook page Feed Widget
HTML entities showing up in feed (6 posts)

  1. dcbaldwin1
    Member
    Posted 2 years ago #

    Any ideas of the best way to fix entities showing up? Maybe string replace or something?

    For example:

    On Facebook:
    "Hello, I hap.....

    What the plugin outputs:
    "Hello, I hap...

    http://wordpress.org/extend/plugins/fbf-facebook-page-feed-widget/

  2. lakshmananphp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    Try using html_entity_decode() function.

    Edit the plugin file, go to line number 99.

    Replace this

    $desc = str_replace('href="', 'href="http://www.facebook.com', $desc_feed);

    with this

    $desc = html_entity_decode(str_replace('href="', 'href="http://www.facebook.com', $desc_feed));

    Let me know if this issue is not resolved

  3. dcbaldwin1
    Member
    Posted 2 years ago #

    Hmm. In theory that should work but it doesn't affect the " or seem to change anything.

    I also tried changing line 98 from:
    $desc_feed = str_replace('href="http://www.facebook.com', 'href="', $block->get_description()); // Emptying all links

    To:
    $desc_feed = html_entity_decode(str_replace('href="http://www.facebook.com', 'href="', $block->get_description()));

    Any other ideas? The facebook page id i'm working with is

  4. dcbaldwin1
    Member
    Posted 2 years ago #

    ...is 155025661192709

  5. lakshmananphp
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, We missed the title!

    Try changing the code in line number 88

    $returnMarkup .= $feedtitle;

    to

    $returnMarkup .= html_entity_decode($feedtitle);

    I've checked your id 155025661192709, the widget works fine.

    Cheers
    Lakshmanan.

  6. dcbaldwin1
    Member
    Posted 2 years ago #

    Very nice. Thanks for the fix and for the awesome plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.