Support » Plugin: wpForo Forum » HTML emails sent as plain text

  • Resolved cutu234

    (@cutu234)


    Hi,
    all emails are sent as plain text including HTML tags. I read that there was a HTML checkbox in the emails tab, but I can’t find one. Where is it? How can I set the plugin to send all emails as HTML? Plain text would be ok, too. But I absolutely don’t want HTML tags to show in the email body text.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Hi @cutu234,
    I’m sure, all emails are being sent as HTML. The issue is in your email reading client. It seems it only shows HTML format by default. What email client you use for checking your emails? You should find an option to enable HTML in that email client.

    Plugin Author gVectors Team

    (@gvectors-team)

    Also, please note, that only the first: user Registration with Password Rest URL email can be sent as Plan text. Because it’s not send by wpForo, it’s sent by WordPress core.

    Thank you very much for the super fast reply!

    The issue is in your email reading client.

    I use Thunderbird. HTML is and has always been enabled. This by no means an issue. By the way, even with HTML disabled, the client would show plain text, but not HTML tags. I have the TinyMCE Advanced plugin activated that keeps the paragraph tags in the text editor view. This shouldn’t be a problem. However, I should mention it.

    Plugin Author gVectors Team

    (@gvectors-team)

    Thunderbird has known issues. So just use other clients you’ll see all is ok.
    More info here: https://wpforo.com/community/how-to-and-troubleshooting-2/activation-link-is-broken-registration-key-is-invalid/#post-26723

    Sorry, but this is NOT a Thunderbird issue. I have NEVER received an email showing plain html tags. I tested it with Outlook 2016: same issue. This is the first time in 10 years working with WordPress that this happens. Don’t get me wrong: Your plugin is awesome. But it is very unlikely that I am the only one facing this problem. In another thread I found a comment on a HTML checkbox in the email tab. I can’t find one. Is it still there? This might explain the problem.

    Thank you.

    Plugin Author gVectors Team

    (@gvectors-team)

    then this is other plugins affection. Some plugin affects email format via WP email hooks. In any case this has no solution from wpForo side. wpForo works correct, but it’s affected by other functions/plugins/theme or hosting filters. You should check in that direction.

    cutu234

    (@cutu234)

    OK, fixed the problem. I had to enable HTML headers in the functions.php:

    add_filter( 'wp_mail', function( $params ) {
        $params['headers'] = 'Content-type: text/html';
        return $params;
    } );
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.