Support » Plugin: Post SMTP Mailer/Email Log » HTML Emails Not showing v2.0.9???

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    Yes, I’m aware, but any tries to get more info from the previous user didn’t succeed.

    Can you give me more details?
    What forms plugin do you use?
    Where is the HTML is broken? User input?

    Thread Starter madebymint

    (@madebymint)

    Hi Yehudah,

    I am using Enfold (https://kriesi.at/themes/enfold-overview/) as my theme. The contact form is built into this theme. I can try and extract more details if you can give me specifics?

    I have ran several test sends via postSMTP. Emails send in plain text. See below example. (Removed full URL incase security issue breach)

    Content-Type: text/plain; charset = "UTF-8" 
    Content-Transfer-Encoding: 8bit 
    
    Hello! 
    
    Sent by Postman 2.0.9 - https://u1******.ct.sendgrid.net/wf/click?upn=WI****** 
    
    Content-Type: text/html; charset=UTF-8 
    Content-Transfer-Encoding: quoted-printable 
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://u1*******.ct.sendgrid.net/wf/click?upn=eFzo-2******">  
    <html xmlns="https://u1*******.ct.sendgrid.net/wf/click?upn=eFzo-2********"> 
    <head> 
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
    <style type="text/css" media="all"> 
    .wporg-notification .im { 
    color: #888; 
    } /* undo a GMail-inserted style */ 
    </style> 
    </head> 
    <body class="wporg-notification"> 
    <div style="background: #e8f6fe; font-family: & quot; Helvetica Neue&quot; , Helvetica ,Arial,sans-serif; font-size: 14px; color: #666; text-align: center; margin: 0; padding: 0"> 
    <table border="0" cellspacing="0" cellpadding="0" bgcolor="#e8f6fe"	style="background: #e8f6fe; width: 100%;"> 
    <tbody> 
    <tr> 
    <td> 
    <table border="0" cellspacing="0" cellpadding="0" align="center" style="padding: 0px; width: 100%;""> 
    <tbody> 
    <tr> 
    <td> 
    <div style="max-width: 600px; height: 400px; margin: 0 auto; overflow: hidden;background-image:url('https://u1******.ct.sendgrid.net/wf/click?upn=W*************-3D no-repeat;"> 
    <div style="margin:50px 0 0 300px; width:300px; font-size:2em;">Hello! - 你好 - Bonjour! - नमस्ते - ¡Hola! - Olá - Привет! - 今日は</div> 
    <div style="text-align:right;font-size: 1.4em; color:black;margin:150px 0 0 200px;">Sent by Postman 2.0.9 
    <br/><span style="font-size: 0.8em"><a style="color:#3f73b9" href="https://u1********.ct.sendgrid.net/wf/click?upn=W*************">https://u1*********.ct.sendgrid.net/wf/click?upn=W*************</a></span> 
    </div> 
    </div> 
    </td> 
    </tr> 
    </tbody> 
    </table> 
    <br><span style="font-size:0.9em;color:#94c0dc;">Image source: <a style="color:#94c0dc" href="https://u1********.ct.sendgrid.net/wf/click?upn=eFzo-2**************">poofytoo.com</a> - Used with permission</span> 
    </td> 
    </tr> 
    </tbody> 
    </table> 
    </body> 
    </html>

    If you need anything else just shout.

    Thanks!

    • This reply was modified 2 years, 5 months ago by madebymint.

    can you try the dev version? upload with FTP.
    https://downloads.wordpress.org/plugin/post-smtp.zip

    If you want you can overwrite one file:
    /post-smtp/Postman/Phpmailer/PostsmtpMailer.php

    Hi Yehudah

    I had the same issue. Some of the diagnostic test content below:

    Mailer: phpmailer
    WordPress: 5.3.2 en_NZ UTF-8
    WordPress Theme: Enfold
    WordPress Plugins: .. Ninja Forms ..
    WordPress wp_mail Owner: /home/alp/public_html/wp-includes/pluggable.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    WordPress wp_mail_from Filter(s): wordfence::fixWPMailFromAddress
    Postman: 2.0.9
    Postman Active Transport: SendGrid API (https://api.sendgrid.com:443)
    Postman Active Transport Status (Ready|Connected): Yes | Yes

    Your one file (PostsmtpMailer.php) fixed the formatting issue but created another. The Ninja contact form I use is supposed to send an email to the form user and one to the webmaster. At the moment it is sending the form user two copies and not sending the version to the webmaster at all.

    Hi,

    Thank you for the update.

    For now please change the mailer method to postsmtp (plugin settings)

    Hi. Thanks. That worked.

    Thread Starter madebymint

    (@madebymint)

    Yep all good here also.

    Thanks!

    Fixed on the new update released now.

    Thanks. I installed the update and tested using Mailer Type > PHPMailer and all is working as it should. Thanks again.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘HTML Emails Not showing v2.0.9???’ is closed to new replies.