Support » Fixing WordPress » HTML editor in 2.2?

  • I had this in 2.0, bu8t finally updated and now I have a tab called code and visual when I write a post.

    How can I get the HTML button back?

    I did check the visual rich ediotr button in my profile and nothing.


Viewing 15 replies - 1 through 15 (of 15 total)
  • Err, html = code.


    Using the “Code” tab is just like using the old “html” button.

    No it’s not at all.

    I was remembering them as the same, just that one was in a popup dialog and the other is in a tab. But moving on…

    Perhaps you’ll want to just disable the tabbed editor?

    Users -> Your Profile, uncheck the top box.

    That’s the “classic” editor.

    It’s a TinyMCE thingy. The editor has built in a HTML editor, which has been turned off from the JavaScript configuration script. In a alternative way, TinyMCE can be turned on/off for a textarea, so this is what the Visual/Code buttons does: toggles on/off the rich text editor. In order to turn back on the HTML editor, search the following file: /wp-includes/js/tinymce/tiny_mce_config.php, search the $mce_buttons variable and add there a new value ‘code’ to the array parsed by the apply_filters(); function.

    Default array:
    Pimped array:

    You can see a new ‘code’ value in the array – that places the ‘HTML’ item in the editor’s bar at the end of the button list. You can control where to place the button, by inserting the ‘code’ value somewhere inside the array.

    I have the same problem, try and put in any html (like P and BR tags) and the editor strips them out.

    So, I did as saltwater said, still no ‘HTML’ button.
    I tried putting ‘code’ into different places in the menu, no difference.

    I must say, the removal of HTML tags is a *REAL* step backwards IMHO, it was great to be able to put in text and type away, then go into the html and make tweaks.

    It’s frustrating that WP has been ‘dumbed down’.

    Please tell us how to get the html back.

    Look up one post and read and you’ll find your answer.



    I added the item in the array and got the tool back. Thanks!



    @lordavon: something is wrong into your configuration or the editor is still cached by the browser.

    Anyway, TinyMCE is very configurable. You can add lots of plugins to it, plugins that are included into the default distribution package, and create the interface that you like.

    Links: – official distribution packages – official documentation – my pimped setup with some extra plugins as example

    I’ve tried adding ‘code’ into the array and it did not work for me either.

    I don’t think it has been dumbed down at all. I perfer the Code tab to the old HTML one. It seems better at helping you maintain web standards.

    The absence of a visual interface maybe not make a difference to a coder, but to anyone else it pretty much makes it useless. It’s a huge step backward. I’ve spent three hours now researching fixes with no success. I had planned on installing this for many clients, but so glad I haven’t yet. I’d be in deep doodoo.

    I had planned on installing this for many clients, but so glad I haven’t yet. I’d be in deep doodoo.

    To be honest… had you installed the wysiwyg animal for your your clients – they would be in a really deep doodoo 🙂
    They all tend to copy/paste from MS Word and that’s the real screw up for any blog. You don’t have thta much time to clean up all that garbage in their posts!
    Don’t even install it or delete it and never tell them there is a wysiwyg thing. They will learn to click on the quicktags and will be happy campers: even when copying from their “favourite” word processor they won’t be able to get the garbage into the posts.

    As for special formatting: usually, they don’t need more than 3-4 things (besides the existing Quikctags), so I just create for them those buttons in the quicktags.js file and everybody is happy.

    just my $0.02

    Yeah, that’s why I paste into notepad first. But anyhow, for those of you who’ve had the same problem, here’s what I finally found worked for me:

    I simply uploaded the plugin and activated it and it actually worked. Uggh! Now back to paying jobs.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘HTML editor in 2.2?’ is closed to new replies.